aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-27 11:10:11 +0000
committerChristopher Baines <mail@cbaines.net>2020-10-27 11:10:11 +0000
commit1a2c255f9fffaa470e67d39ffcb94d3f9e9ed933 (patch)
tree6b7cc5866f400ce977acb6f25ed25879d0c830c7
parent7a570a47beabc13b40aa7da218caba4fef9b456a (diff)
downloadguix-1a2c255f9fffaa470e67d39ffcb94d3f9e9ed933.tar
guix-1a2c255f9fffaa470e67d39ffcb94d3f9e9ed933.tar.gz
rust-aes-soft-0.3
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9356050444..029704420b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -323,6 +323,33 @@ acceleration.")
AES (Rijndael) block ciphers.")
(license (list license:expat license:asl2.0))))
+(define-public rust-aes-soft-0.3
+ (package
+ (name "rust-aes-soft")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "aes-soft" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cj1i8fzgs48b094gd1p2vc8nashs228asacblmy2131wn964plr"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-block-cipher" ,rust-block-cipher-0.7)
+ ("rust-byteorder" ,rust-byteorder-1)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.2)
+ ("rust-byte-tools" ,rust-byte-tools-0.2))
+ #:cargo-development-inputs
+ (("rust-block-cipher" ,rust-block-cipher-0.7))))
+ (home-page "https://github.com/RustCrypto/block-ciphers")
+ (synopsis "Bit-sliced implementation of AES (Rijndael) block ciphers")
+ (description "This package provides a bit-sliced implementation of
+AES (Rijndael) block ciphers.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-aesni-0.7
(package
(name "rust-aesni")