aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-01 19:13:23 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 22:22:51 +0200
commitf5efb4271d28fe54ac68af9924711b6033f744e9 (patch)
treee82ad918f9943fd7fb53b49117927380aa2dbfce
parent9c852ae229762a54e98337522d65ae64bc757a48 (diff)
downloadguix-f5efb4271d28fe54ac68af9924711b6033f744e9.tar
guix-f5efb4271d28fe54ac68af9924711b6033f744e9.tar.gz
gnu: gtk-vnc: Remove input labels.
* gnu/packages/gnome.scm (gtk-vnc)[native-inputs]: Remove labels.
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4b9d3ed217..9e8b68de33 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8873,19 +8873,20 @@ like switching to windows and launching applications.")
(arguments
`(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
(native-inputs
- `(;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
- ;; dependency on other platforms (FIXME).
- ,@(if (target-x86-64?)
- `(("gjs" ,gjs))
- '())
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("intltool" ,intltool)
- ("node" ,node)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("vala" ,vala)))
+ (append
+ ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
+ ;; dependency on other platforms (FIXME).
+ (if (target-x86-64?)
+ (list gjs)
+ '())
+ (list `(,glib "bin")
+ gobject-introspection
+ intltool
+ node
+ perl
+ pkg-config
+ python-wrapper
+ vala)))
(inputs
(list cairo (librsvg-for-system)))
(propagated-inputs