aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-08-23 21:10:13 +0300
committerMathieu Othacehe <othacehe@gnu.org>2022-09-02 09:34:49 +0200
commitb11d029ca3b0fe024fd701a35460ff66b52725ab (patch)
tree0f66211d39af9c674308507f11f51e728a2ad7e9
parent85b5603eb28d00b4c26db8b9a62f85655f466a49 (diff)
downloadguix-b11d029ca3b0fe024fd701a35460ff66b52725ab.tar
guix-b11d029ca3b0fe024fd701a35460ff66b52725ab.tar.gz
gnu: guile-smc: Update to 0.5.2.
* gnu/packages/guile-xyz.scm (guile-smc): Update to 0.5.2. [arguments]: Remove the patch phase that is not needed anymore. Remove a trailing #t in the wrap-program phase. [native-inputs]: Add "help2man" and "which". [inputs]: Use the new inputs style. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm31
1 files changed, 5 insertions, 26 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 8ba38c87d8..d09cedab26 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4864,7 +4864,7 @@ GitLab instance.")
(define-public guile-smc
(package
(name "guile-smc")
- (version "0.3.0")
+ (version "0.5.2")
(source
(origin
(method git-fetch)
@@ -4874,7 +4874,7 @@ GitLab instance.")
(file-name (string-append name "-" version))
(sha256
(base32
- "0szkjmasi70m1vppck7nhdxg4lnxzjq6mihi6r1552s8sxm5z008"))))
+ "05q20vi59whjs7jb8bgcxnnfy6c3wx26m5ps2fwlsz52nggarxzb"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
@@ -4886,23 +4886,6 @@ GitLab instance.")
#:phases
(modify-phases %standard-phases
(delete 'strip)
- (add-after 'configure 'patch
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "modules/smc/core/log.scm"
- ((" #:use-module \\(logging logger\\)")
- (string-append
- " #:use-module (logging logger)\n"
- " #:use-module (logging rotating-log)"))
- (("#:init-value \"logger\"")
- (format #f
- "#:init-value \"~a/bin/logger\""
- (assoc-ref inputs "inetutils")))
- (("\\(add-handler! %logger %syslog\\)")
- (string-append
- "(add-handler! %logger\n"
- " (make <rotating-log>\n"
- " #:file-name \"smc.log\"))\n")))
- #t))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -4919,15 +4902,11 @@ GitLab instance.")
,(string-append guile-lib scm)))
`("GUILE_LOAD_COMPILED_PATH" prefix
(,(string-append out go)
- ,(string-append guile-lib go)))))
- #t)))))
+ ,(string-append guile-lib go))))))))))
(native-inputs
- (list autoconf automake pkg-config texinfo))
+ (list autoconf automake pkg-config texinfo help2man which))
(inputs
- `(("bash" ,bash-minimal)
- ("guile" ,guile-3.0)
- ("guile-lib" ,guile-lib)
- ("inetutils" ,inetutils)))
+ (list bash-minimal guile-3.0 guile-lib inetutils))
(home-page "https://github.com/artyom-poptsov/guile-smc")
(synopsis "GNU Guile state machine compiler")
(description