aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2022-02-21 21:03:44 +1100
committerMarius Bakke <marius@gnu.org>2022-09-01 16:08:16 +0200
commita0cc28346f6236ff0bae6f0854943275616d36f5 (patch)
treecbadfd9ca5a06da97b0342984bf40fce86472ffd
parent39460eac6d28a1b48c4e12dce80c2bf5015eeeb8 (diff)
downloadguix-a0cc28346f6236ff0bae6f0854943275616d36f5.tar
guix-a0cc28346f6236ff0bae6f0854943275616d36f5.tar.gz
gnu: Add wayland-protocols 1.26.
* gnu/packages/freedesktop.scm (wayland-protocols-next): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/freedesktop.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d7cd2cdf40..d82a4347b1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1090,6 +1090,21 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
+;;; This is just a temporary package that should be deleted
+(define-public wayland-protocols-next
+ (package
+ (inherit wayland-protocols)
+ (name "wayland-protocols")
+ (version "1.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://wayland.freedesktop.org/releases/"
+ "wayland-protocols-" version ".tar.xz"))
+ (sha256
+ (base32
+ "04vgllmpmrv14x3x64ns01vgwx4hriljayjkz9idgbv83i63hly5"))))))
+
(define-public waylandpp
(package
(name "waylandpp")