aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-09-01 19:23:25 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-01 20:36:42 +0200
commit839349e187170c396899c134762389e88026b84f (patch)
treed73d650a05ab5291c2a090993e0dd69aef41c629
parentcd10a235d9e027c0851e9b47f76288d0bfca8a9b (diff)
downloadguix-839349e187170c396899c134762389e88026b84f.tar
guix-839349e187170c396899c134762389e88026b84f.tar.gz
gnu: csdr: Update to 0.18.0.
* gnu/packages/radio.scm (csdr): Update to 0.18.0. [source, home-page]: Switch to maintained repository. [build-system]: Switch to cmake-build-system. [native-inputs]: Add pkg-config. [inputs]: Add libsamplerate. [arguments]: Remove custom 'make-flags' and phases.
-rw-r--r--gnu/packages/radio.scm74
1 files changed, 24 insertions, 50 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index bc2c13b847..41bd3e38a9 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1945,59 +1945,33 @@ defined radio with support for rtl-sdr.")
(license license:gpl2+)))
(define-public csdr
- ;; No release since 2017, use commit directly.
- (let ((commit "6ef2a74206887155290a54c7117636f66742f858")
- (revision "1"))
- (package
- (name "csdr")
- (version (git-version "0.15" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ha7ilm/csdr")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0ic35130lf66lk3wawgc5bcg711l7chv9al1hzdc1xrmq9qf9hri"))))
- (build-system gnu-build-system)
- (inputs
- (list fftwf))
- (arguments
- `(#:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- ;; Don't print summary of SIMD optimized functions.
- "PARSEVECT=no")
- #:tests? #f ; No check phase
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("PARAMS_MISC = -Wno-unused-result" all)
- ;; The 'validate-runpath' phase fails without this.
- (string-append
- all " -Wl,-rpath=" (assoc-ref outputs "out") "/lib"))
- (("PARAMS_SIMD =.*")
- ;; Disable to make reproducibility and cross-compilation work.
- "")
- (("gcc ")
- ,(string-append (cc-for-target) " "))
- (("g\\+\\+ ")
- ,(string-append (cxx-for-target) " ")))))
- (add-before 'install 'make-installation-directories
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/bin"))
- (mkdir-p (string-append out "/lib"))))))))
- (home-page "https://github.com/ha7ilm/csdr")
- (synopsis "DSP for software defined radio")
- (description
- "This package includes the @code{libcsdr} library of
+ (package
+ (name "csdr")
+ (version "0.18.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jketterl/csdr")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sdni0p9qcf4yw1wf5jz1pyb9wv6wmdblirh2q6s7jblh50vfwz1"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list fftwf libsamplerate))
+ (arguments
+ (list #:tests? #f)) ; No check phase
+ (home-page "https://github.com/jketterl/csdr")
+ (synopsis "DSP for software defined radio")
+ (description
+ "This package includes the @code{libcsdr} library of
@acronym{DSP, Digital Signal Processing} functions for
@acronym{SDRs, Software Defined Radios}, and the @code{csdr} command line
program that can be used to build simple signal processing flow graphs.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public serialdv
(package