aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 19:09:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 23:30:26 +0100
commiteab9807fb38b70e203ac965f2705c76adaedcc07 (patch)
treeb7abb32d631fed990528690e719995cbd48eae87
parentc11b541fba8131e701b55c5c7ef1a412bb4d1fc8 (diff)
downloadguix-eab9807fb38b70e203ac965f2705c76adaedcc07.tar
guix-eab9807fb38b70e203ac965f2705c76adaedcc07.tar.gz
gnu: r-biocparallel: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-biocparallel): Move from here... * gnu/packages/bioconductor.scm (r-biocparallel): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm27
-rw-r--r--gnu/packages/bioinformatics.scm27
2 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 897e85dfe3..6482d8e4c1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1659,6 +1659,33 @@ users direct access to a diverse set of data and enable a wide range of
powerful online queries from gene annotation to database mining.")
(license license:artistic2.0)))
+(define-public r-biocparallel
+ (package
+ (name "r-biocparallel")
+ (version "1.24.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiocParallel" version))
+ (sha256
+ (base32
+ "1iryicvmcagcrj29kp49mqhiq2kn72j4idj380hi9illmdrg9ism"))))
+ (properties
+ `((upstream-name . "BiocParallel")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-futile-logger" ,r-futile-logger)
+ ("r-snow" ,r-snow)
+ ("r-bh" ,r-bh)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/BiocParallel")
+ (synopsis "Bioconductor facilities for parallel evaluation")
+ (description
+ "This package provides modified versions and novel implementation of
+functions for parallel evaluation, tailored to use with Bioconductor
+objects.")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-category
(package
(name "r-category")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 289a96f572..af3fa36b19 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,33 +7691,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-biocparallel
- (package
- (name "r-biocparallel")
- (version "1.24.1")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "BiocParallel" version))
- (sha256
- (base32
- "1iryicvmcagcrj29kp49mqhiq2kn72j4idj380hi9illmdrg9ism"))))
- (properties
- `((upstream-name . "BiocParallel")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-futile-logger" ,r-futile-logger)
- ("r-snow" ,r-snow)
- ("r-bh" ,r-bh)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/BiocParallel")
- (synopsis "Bioconductor facilities for parallel evaluation")
- (description
- "This package provides modified versions and novel implementation of
-functions for parallel evaluation, tailored to use with Bioconductor
-objects.")
- (license (list license:gpl2+ license:gpl3+))))
-
(define-public r-biostrings
(package
(name "r-biostrings")