aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 19:08:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 23:30:26 +0100
commite56b3db82ea81e88632a15994a5792849ecb0c5c (patch)
treed1f601f1c5746e133fc33fdadbe8ae4de5345ad5
parent821e6439212f8e94580674eaaff2ce6752cd3b18 (diff)
downloadguix-e56b3db82ea81e88632a15994a5792849ecb0c5c.tar
guix-e56b3db82ea81e88632a15994a5792849ecb0c5c.tar.gz
gnu: r-xvector: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-xvector): Move from here... * gnu/packages/bioconductor.scm (r-xvector): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm36
-rw-r--r--gnu/packages/bioinformatics.scm36
2 files changed, 36 insertions, 36 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 379b6c30c0..fdb2f7c7ac 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2108,6 +2108,42 @@ annotation infrastructure.")
coding changes and predict coding outcomes.")
(license license:artistic2.0)))
+(define-public r-xvector
+ (package
+ (name "r-xvector")
+ (version "0.30.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "XVector" version))
+ (sha256
+ (base32
+ "1pqljikg4f6jb7wgm5537zwgq5b013nyz1agjrwfq2cljb0ym6lq"))))
+ (properties
+ `((upstream-name . "XVector")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-system-zlib
+ (lambda _
+ (substitute* "DESCRIPTION"
+ (("zlibbioc, ") ""))
+ (substitute* "NAMESPACE"
+ (("import\\(zlibbioc\\)") ""))
+ #t)))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-iranges" ,r-iranges)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://bioconductor.org/packages/XVector")
+ (synopsis "Representation and manpulation of external sequences")
+ (description
+ "This package provides memory efficient S4 classes for storing sequences
+\"externally\" (behind an R external pointer, or on disk).")
+ (license license:artistic2.0)))
+
(define-public r-geneplotter
(package
(name "r-geneplotter")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9774b442a3..65db983461 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,42 +7691,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-xvector
- (package
- (name "r-xvector")
- (version "0.30.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "XVector" version))
- (sha256
- (base32
- "1pqljikg4f6jb7wgm5537zwgq5b013nyz1agjrwfq2cljb0ym6lq"))))
- (properties
- `((upstream-name . "XVector")))
- (build-system r-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'use-system-zlib
- (lambda _
- (substitute* "DESCRIPTION"
- (("zlibbioc, ") ""))
- (substitute* "NAMESPACE"
- (("import\\(zlibbioc\\)") ""))
- #t)))))
- (inputs
- `(("zlib" ,zlib)))
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-iranges" ,r-iranges)
- ("r-s4vectors" ,r-s4vectors)))
- (home-page "https://bioconductor.org/packages/XVector")
- (synopsis "Representation and manpulation of external sequences")
- (description
- "This package provides memory efficient S4 classes for storing sequences
-\"externally\" (behind an R external pointer, or on disk).")
- (license license:artistic2.0)))
-
(define-public r-genomicranges
(package
(name "r-genomicranges")