aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 19:09:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 23:30:26 +0100
commitd99a18252c31fb2c19e3e7ae65bb36e85c3aa1af (patch)
tree73d23bbfd84ab51d5eb1d31cc83fdf1b8f06bb20
parentadf45daae93219a31dbabd8dd80a806cc747aa81 (diff)
downloadguix-d99a18252c31fb2c19e3e7ae65bb36e85c3aa1af.tar
guix-d99a18252c31fb2c19e3e7ae65bb36e85c3aa1af.tar.gz
gnu: r-delayedarray: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-delayedarray): Move from here... * gnu/packages/bioconductor.scm (r-delayedarray): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm33
-rw-r--r--gnu/packages/bioinformatics.scm33
2 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c659bdd09e..9212165706 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1212,6 +1212,39 @@ data. In addition, provides numerous plotting functions for commonly
used visualizations.")
(license license:artistic2.0)))
+(define-public r-delayedarray
+ (package
+ (name "r-delayedarray")
+ (version "0.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DelayedArray" version))
+ (sha256
+ (base32
+ "09lpj951v1afxkrnjvnhzp4qgklq23ykdwlny7k1lyfcdy9q6wm0"))))
+ (properties
+ `((upstream-name . "DelayedArray")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-iranges" ,r-iranges)
+ ("r-matrix" ,r-matrix)
+ ("r-matrixgenerics" ,r-matrixgenerics)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/DelayedArray")
+ (synopsis "Delayed operations on array-like objects")
+ (description
+ "Wrapping an array-like object (typically an on-disk object) in a
+@code{DelayedArray} object allows one to perform common array operations on it
+without loading the object in memory. In order to reduce memory usage and
+optimize performance, operations on the object are either delayed or executed
+using a block processing mechanism. Note that this also works on in-memory
+array-like objects like @code{DataFrame} objects (typically with Rle columns),
+@code{Matrix} objects, and ordinary arrays and data frames.")
+ (license license:artistic2.0)))
+
(define-public r-bluster
(package
(name "r-bluster")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 05805d1a8b..bc342b5de8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,39 +7691,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-delayedarray
- (package
- (name "r-delayedarray")
- (version "0.16.2")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "DelayedArray" version))
- (sha256
- (base32
- "09lpj951v1afxkrnjvnhzp4qgklq23ykdwlny7k1lyfcdy9q6wm0"))))
- (properties
- `((upstream-name . "DelayedArray")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-s4vectors" ,r-s4vectors)
- ("r-iranges" ,r-iranges)
- ("r-matrix" ,r-matrix)
- ("r-matrixgenerics" ,r-matrixgenerics)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/DelayedArray")
- (synopsis "Delayed operations on array-like objects")
- (description
- "Wrapping an array-like object (typically an on-disk object) in a
-@code{DelayedArray} object allows one to perform common array operations on it
-without loading the object in memory. In order to reduce memory usage and
-optimize performance, operations on the object are either delayed or executed
-using a block processing mechanism. Note that this also works on in-memory
-array-like objects like @code{DataFrame} objects (typically with Rle columns),
-@code{Matrix} objects, and ordinary arrays and data frames.")
- (license license:artistic2.0)))
-
(define-public r-summarizedexperiment
(package
(name "r-summarizedexperiment")