aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 19:09:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 23:30:26 +0100
commitc11b541fba8131e701b55c5c7ef1a412bb4d1fc8 (patch)
tree0ac5755286d439b0702f996317e6b7bd9e050e69
parent16c7e79ebbe911a1e8cb7ad8d9cb1c5d8ede34c7 (diff)
downloadguix-c11b541fba8131e701b55c5c7ef1a412bb4d1fc8.tar
guix-c11b541fba8131e701b55c5c7ef1a412bb4d1fc8.tar.gz
gnu: r-biomart: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-biomart): Move from here... * gnu/packages/bioconductor.scm (r-biomart): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm38
-rw-r--r--gnu/packages/bioinformatics.scm38
2 files changed, 38 insertions, 38 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2ae212dfac..897e85dfe3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1621,6 +1621,44 @@ databases. Packages produced are intended to be used with AnnotationDbi.")
on Bioconductor or which replace R functions.")
(license license:artistic2.0)))
+(define-public r-biomart
+ (package
+ (name "r-biomart")
+ (version "2.46.3")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "biomaRt" version))
+ (sha256
+ (base32
+ "0gwmd0ykpv0gyh34c56g5m12lil20fvig49f3ih1jxrxf3q4wmq7"))))
+ (properties
+ `((upstream-name . "biomaRt")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biocfilecache" ,r-biocfilecache)
+ ("r-httr" ,r-httr)
+ ("r-openssl" ,r-openssl)
+ ("r-progress" ,r-progress)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-stringr" ,r-stringr)
+ ("r-xml" ,r-xml)
+ ("r-xml2" ,r-xml2)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/biomaRt")
+ (synopsis "Interface to BioMart databases")
+ (description
+ "biomaRt provides an interface to a growing collection of databases
+implementing the @url{BioMart software suite, http://www.biomart.org}. The
+package enables retrieval of large amounts of data in a uniform way without
+the need to know the underlying database schemas or write complex SQL queries.
+Examples of BioMart databases are Ensembl, COSMIC, Uniprot, HGNC, Gramene,
+Wormbase and dbSNP mapped to Ensembl. These major databases give biomaRt
+users direct access to a diverse set of data and enable a wide range of
+powerful online queries from gene annotation to database mining.")
+ (license license:artistic2.0)))
+
(define-public r-category
(package
(name "r-category")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a45196bc5b..289a96f572 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,44 +7691,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-biomart
- (package
- (name "r-biomart")
- (version "2.46.3")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "biomaRt" version))
- (sha256
- (base32
- "0gwmd0ykpv0gyh34c56g5m12lil20fvig49f3ih1jxrxf3q4wmq7"))))
- (properties
- `((upstream-name . "biomaRt")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotationdbi" ,r-annotationdbi)
- ("r-biocfilecache" ,r-biocfilecache)
- ("r-httr" ,r-httr)
- ("r-openssl" ,r-openssl)
- ("r-progress" ,r-progress)
- ("r-rappdirs" ,r-rappdirs)
- ("r-stringr" ,r-stringr)
- ("r-xml" ,r-xml)
- ("r-xml2" ,r-xml2)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/biomaRt")
- (synopsis "Interface to BioMart databases")
- (description
- "biomaRt provides an interface to a growing collection of databases
-implementing the @url{BioMart software suite, http://www.biomart.org}. The
-package enables retrieval of large amounts of data in a uniform way without
-the need to know the underlying database schemas or write complex SQL queries.
-Examples of BioMart databases are Ensembl, COSMIC, Uniprot, HGNC, Gramene,
-Wormbase and dbSNP mapped to Ensembl. These major databases give biomaRt
-users direct access to a diverse set of data and enable a wide range of
-powerful online queries from gene annotation to database mining.")
- (license license:artistic2.0)))
-
(define-public r-biocparallel
(package
(name "r-biocparallel")