aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 19:08:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 23:30:26 +0100
commit821e6439212f8e94580674eaaff2ce6752cd3b18 (patch)
tree1f84b3657f28d19d3cb92a42634ba5d99acaff80
parent74fdd0fea08fde451ad1a9d43abeeab27c422383 (diff)
downloadguix-821e6439212f8e94580674eaaff2ce6752cd3b18.tar
guix-821e6439212f8e94580674eaaff2ce6752cd3b18.tar.gz
gnu: r-limma: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-limma): Move from here... * gnu/packages/bioconductor.scm (r-limma): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm19
-rw-r--r--gnu/packages/bioinformatics.scm19
2 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d611f3a491..379b6c30c0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1850,6 +1850,25 @@ Enrichment Analysis} (GSEA).")
the Human Protein Atlas project.")
(license license:artistic2.0)))
+(define-public r-limma
+ (package
+ (name "r-limma")
+ (version "3.46.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "limma" version))
+ (sha256
+ (base32
+ "1xxv493q1kip9bjfv7v7k5dnq7hz7gvl80i983v4mvwavhgnbxfz"))))
+ (build-system r-build-system)
+ (home-page "http://bioinf.wehi.edu.au/limma")
+ (synopsis "Package for linear models for microarray and RNA-seq data")
+ (description "This package can be used for the analysis of gene expression
+studies, especially the use of linear models for analysing designed experiments
+and the assessment of differential expression. The analysis methods apply to
+different technologies, including microarrays, RNA-seq, and quantitative PCR.")
+ (license license:gpl2+)))
+
(define-public r-rbgl
(package
(name "r-rbgl")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d9afe2c56f..9774b442a3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,25 +7691,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-limma
- (package
- (name "r-limma")
- (version "3.46.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "limma" version))
- (sha256
- (base32
- "1xxv493q1kip9bjfv7v7k5dnq7hz7gvl80i983v4mvwavhgnbxfz"))))
- (build-system r-build-system)
- (home-page "http://bioinf.wehi.edu.au/limma")
- (synopsis "Package for linear models for microarray and RNA-seq data")
- (description "This package can be used for the analysis of gene expression
-studies, especially the use of linear models for analysing designed experiments
-and the assessment of differential expression. The analysis methods apply to
-different technologies, including microarrays, RNA-seq, and quantitative PCR.")
- (license license:gpl2+)))
-
(define-public r-xvector
(package
(name "r-xvector")