aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 19:08:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 23:30:26 +0100
commit457de7f401300085066a0426068fe75f8df85943 (patch)
tree27449dfb174b2ef1b75108515ab835b61a57de1a
parentf3f09b99cd32f46c47db30f0afb632614c43172d (diff)
downloadguix-457de7f401300085066a0426068fe75f8df85943.tar
guix-457de7f401300085066a0426068fe75f8df85943.tar.gz
gnu: r-biobase: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-biobase): Move from here... * gnu/packages/bioconductor.scm (r-biobase): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm22
-rw-r--r--gnu/packages/bioinformatics.scm22
2 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ec273cae70..b7308848c0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1570,6 +1570,28 @@ microarrays.")
databases. Packages produced are intended to be used with AnnotationDbi.")
(license license:artistic2.0)))
+(define-public r-biobase
+ (package
+ (name "r-biobase")
+ (version "2.50.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Biobase" version))
+ (sha256
+ (base32
+ "11kgc4flywlm3i18603558l8ksv91c24vkc5fnnbcd375i2dhhd4"))))
+ (properties
+ `((upstream-name . "Biobase")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)))
+ (home-page "https://bioconductor.org/packages/Biobase")
+ (synopsis "Base functions for Bioconductor")
+ (description
+ "This package provides functions that are needed by many other packages
+on Bioconductor or which replace R functions.")
+ (license license:artistic2.0)))
+
(define-public r-category
(package
(name "r-category")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4889c148e4..b73862ff86 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,28 +7691,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-biobase
- (package
- (name "r-biobase")
- (version "2.50.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "Biobase" version))
- (sha256
- (base32
- "11kgc4flywlm3i18603558l8ksv91c24vkc5fnnbcd375i2dhhd4"))))
- (properties
- `((upstream-name . "Biobase")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)))
- (home-page "https://bioconductor.org/packages/Biobase")
- (synopsis "Base functions for Bioconductor")
- (description
- "This package provides functions that are needed by many other packages
-on Bioconductor or which replace R functions.")
- (license license:artistic2.0)))
-
(define-public r-annotationdbi
(package
(name "r-annotationdbi")