aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-05-17 21:00:54 +0100
committerChristopher Baines <mail@cbaines.net>2020-05-17 21:00:54 +0100
commita6eabc572445869e0494a2b9962407352bb86c1d (patch)
tree1b0da65c226d5ea2dafa99b428c2a8037af1fd08 /Makefile.am
parentaad8a02d33b3d35f946dd0e03289306b9d9af703 (diff)
downloadbuild-coordinator-a6eabc572445869e0494a2b9962407352bb86c1d.tar
build-coordinator-a6eabc572445869e0494a2b9962407352bb86c1d.tar.gz
Convert the client actions to happen over HTTP
There were a few issues with the previous approach, I was concerned about trying to write to the SQLite database from two processes, it's already segfaulting occasionally when accessing it from just one. Additionally, the client actions were already doing things that should happen in the coordinator process, like allocating builds. I'm trying to not turn this in to a web app, but not doing very well. Although having this information and these actions available over the network does make it possible to build a web app frontend, which I've had in mind.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 747c597..59af3c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,6 +9,7 @@ SOURCES = \
guix-build-coordinator/agent-messaging/http.scm \
guix-build-coordinator/agent.scm \
guix-build-coordinator/build-allocator.scm \
+ guix-build-coordinator/client-communication.scm \
guix-build-coordinator/config.scm \
guix-build-coordinator/coordinator.scm \
guix-build-coordinator/datastore.scm \