aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-04-13 09:56:34 +0100
committerChristopher Baines <mail@cbaines.net>2023-04-13 16:41:30 +0100
commit27c8de16b55dfe70180f0e17e12f442696708a53 (patch)
tree0c9260025f28b6948629e79762183b480fe52254 /configure.ac
downloadbffe-27c8de16b55dfe70180f0e17e12f442696708a53.tar
bffe-27c8de16b55dfe70180f0e17e12f442696708a53.tar.gz
Initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c660bc0
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+dnl -*- Autoconf -*-
+
+AC_INIT([bffe], [m4_translit(m4_esyscmd([cat VERSION]),m4_newline)])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([gnu color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+GUILE_PKG([3.0])
+GUILE_PROGS
+if test "x$GUILD" = "x"; then
+ AC_MSG_ERROR(['guild' binary not found; please check your guile-2.2 installation.])
+fi
+
+GUILE_MODULE_AVAILABLE([have_json], [(json)])
+if test "x$have_json" != "xyes"; then
+ AC_MSG_ERROR([Guile-JSON is missing; please install it.])
+fi
+
+GUILE_MODULE_AVAILABLE([have_fibers], [(fibers web server)])
+if test "x$have_fibers" != "xyes"; then
+ AC_MSG_ERROR([Guile fibers is missing; please install it.])
+fi
+
+guilemoduledir="${datarootdir}/guile/site/${GUILE_EFFECTIVE_VERSION}"
+AC_SUBST([guilemoduledir])
+AC_SUBST([GUILE_EFFECTIVE_VERSION])
+
+AC_PATH_PROG([guix], [guix])
+
+dnl Substitute placeholders to generate these target files
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([scripts/bffe], [chmod +x scripts/bffe])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+AC_OUTPUT