aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-04-13 09:56:34 +0100
committerChristopher Baines <mail@cbaines.net>2023-04-13 16:41:30 +0100
commit27c8de16b55dfe70180f0e17e12f442696708a53 (patch)
tree0c9260025f28b6948629e79762183b480fe52254 /Makefile.am
downloadbffe-27c8de16b55dfe70180f0e17e12f442696708a53.tar
bffe-27c8de16b55dfe70180f0e17e12f442696708a53.tar.gz
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..bcbec65
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,38 @@
+# bffe
+#
+# Copyright © 2023 Christopher Baines <mail@cbaines.net>
+#
+# This file is part of bffe.
+#
+# bffe is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 3 of the
+# License, or (at your option) any later version.
+#
+# bffe is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with the bffe. If not, see
+# <http://www.gnu.org/licenses/>.
+
+include guile.am
+
+bin_SCRIPTS = \
+ scripts/bffe
+
+moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir = $(prefix)/lib/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
+assetsdir = $(datadir)/@PACKAGE@
+
+SOURCES = \
+ bffe/server.scm \
+ bffe/view/util.scm \
+ bffe/view/home.scm \
+ bffe/view/activity.scm
+
+install-data-local:
+ mkdir -p "$(DESTDIR)$(pkgdatadir)" || exit 1;
+ cp -r assets "$(DESTDIR)$(pkgdatadir)/" || exit 1;