summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/rails.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index 86ce1514f0..cc1421f6b7 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -123,6 +123,40 @@ API.")
"https://github.com/banister/debug_inspector")
(license license:expat)))
+(define-public ruby-annotate
+ (package
+ (name "ruby-annotate")
+ (version "2.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "annotate" version))
+ (sha256
+ (base32
+ "079y33iy65nv1cqnh1zmi3v2y9yp1z3zzsf2wdh35m3c80v6kaz4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-annotate
+ (lambda _
+ (substitute* "bin/annotate"
+ (("require 'bundler'")
+ "")
+ (("Bundler.setup")
+ "")))))))
+ (propagated-inputs
+ `(("ruby-activerecord" ,ruby-activerecord)
+ ("ruby-activesupport" ,ruby-activesupport)))
+ (synopsis
+ "Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.")
+ (description
+ "Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.")
+ (home-page
+ "http://github.com/ctran/annotate_models")
+ (license #f)))
+
(define-public ruby-autoprefixer-rails
(package
(name "ruby-autoprefixer-rails")