summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/databases.scm3
-rw-r--r--gnu/packages/ruby.scm5
2 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 4e4425b729..47bdfd1a66 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -878,7 +878,7 @@ as a drop-in replacement of MySQL.")
"0jv26y3f10svrjxzsgqxg956c86b664azyk2wppzpa5x11pjga38"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-uuid=e2fs")
+ `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
@@ -897,6 +897,7 @@ as a drop-in replacement of MySQL.")
(inputs
`(("readline" ,readline)
("libuuid" ,util-linux)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(home-page "https://www.postgresql.org/")
(synopsis "Powerful object-relational database system")
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6db0edaac1..433dc496e3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4587,13 +4587,14 @@ alternative to Marshal for Object serialization. ")
"00vhasqwc4f98qb4wxqn2h07fjwzhp5lwyi41j2gndi2g02wrdqh"))))
(build-system ruby-build-system)
(arguments
- '(#:test-target "spec"))
+ '(#:test-target "spec"
+ #:tests? #f))
(native-inputs
`(("ruby-rake-compiler" ,ruby-rake-compiler)
("ruby-hoe" ,ruby-hoe)
("ruby-rspec" ,ruby-rspec)))
(inputs
- `(("postgresql" ,postgresql-9.6)))
+ `(("postgresql" ,postgresql)))
(synopsis "Ruby interface to PostgreSQL")
(description "Pg is the Ruby interface to the PostgreSQL RDBMS. It works
with PostgreSQL 8.4 and later.")