summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-03 22:03:34 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-03-24 01:06:29 +0000
commitd7df5321d15faaf949269057c4541943914d8554 (patch)
treee122b034bc90efd613952db6ff152ec9ed7442a2
parente7f30f72e7f309fb3263a57e94e9df82d293bfcc (diff)
downloadgnu-guix-release_31.tar
gnu-guix-release_31.tar.gz
gnu: postgresql: Build with openssl support.release_31
* gnu/packages/databases.scm (postgresql)[arguments]: Add --with-openssl to [inputs]: Add openssl.
-rw-r--r--gnu/packages/databases.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 511d73e6fe..e3818a2570 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -761,7 +761,7 @@ as a drop-in replacement of MySQL.")
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-uuid=e2fs")
+ `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
@@ -780,6 +780,7 @@ as a drop-in replacement of MySQL.")
(inputs
`(("readline" ,readline)
("libuuid" ,util-linux)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(home-page "https://www.postgresql.org/")
(synopsis "Powerful object-relational database system")