aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-03-01 00:33:37 -0500
committerNick Mathewson <nickm@torproject.org>2013-03-01 00:33:37 -0500
commitc72d58cbfff0b0a5e7d9fd226e556c225bb92a76 (patch)
tree557a2d845a6049de0ce92ec81537088973e92eea /configure.ac
parent94d0f226e654af787407b089295ee078eab84c7b (diff)
parent97d0872f59b4ac7a56632966ee041782c1152313 (diff)
downloadtor-c72d58cbfff0b0a5e7d9fd226e556c225bb92a76.tar
tor-c72d58cbfff0b0a5e7d9fd226e556c225bb92a76.tar.gz
Merge remote-tracking branch 'public/feature8109'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8cefc1850..3dcf90a54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -584,6 +584,19 @@ if test x$enable_linker_hardening != xno; then
fi
dnl ------------------------------------------------------
+dnl Now see if we have a -fomit-frame-pointer compiler option.
+
+saved_CFLAGS="$CFLAGS"
+TOR_CHECK_CFLAGS(-fomit-frame-pointer)
+if test "$saved_CFLAGS" != "$CFLAGS"; then
+ F_OMIT_FRAME_POINTER='-fomit-frame-pointer'
+else
+ F_OMIT_FRAME_POINTER=''
+fi
+CFLAGS="$saved_CFLAGS"
+AC_SUBST(F_OMIT_FRAME_POINTER)
+
+dnl ------------------------------------------------------
dnl Where do you live, libnatpmp? And how do we call you?
dnl There are no packages for Debian or Redhat as of this patch