aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2010-06-16 15:43:42 -0400
committerJoey Hess <joey@kitenet.net>2010-06-16 15:43:42 -0400
commit062ed44f47d61c3bbbf2e8a7944a9b4e423b735a (patch)
tree9b3624aea731a7c30981305e4babf8cf4d0d6d28 /Makefile.PL
parenta748f283ace7ff83ac4630674d58767fd2540d8a (diff)
downloadikiwiki-062ed44f47d61c3bbbf2e8a7944a9b4e423b735a.tar
ikiwiki-062ed44f47d61c3bbbf2e8a7944a9b4e423b735a.tar.gz
add theme plugin
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4001c841b..29ec9c209 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -78,7 +78,19 @@ underlay_install:
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/directives/ikiwiki/directive; \
fi \
done
-
+
+ # Themes have their style.css appended to the normal one.
+ for theme in themes/*; do \
+ install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$theme; \
+ for file in $$theme/*; do \
+ if echo "$$file" | grep -q style.css; then \
+ (cat doc/style.css; cat $$file) >> $(DESTDIR)$(PREFIX)/share/ikiwiki/$$theme/style.css; \
+ elif [ -f "$$file" ]; then \
+ install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$file; \
+ fi \
+ done; \
+ done
+
extra_install: underlay_install
# Install example sites.
for dir in `cd doc/examples; find . -type d ! -regex '.*\.svn.*'`; do \