aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-08-12 15:15:54 +0100
committerChristopher Baines <mail@cbaines.net>2022-08-12 15:15:54 +0100
commitcd14c8daa1cee5dd81d333401d98026a67c78c90 (patch)
treedab3f80fd9ffa9e20b4e82104af5625b68521035 /Makefile.am
downloadqa-frontpage-cd14c8daa1cee5dd81d333401d98026a67c78c90.tar
qa-frontpage-cd14c8daa1cee5dd81d333401d98026a67c78c90.tar.gz
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6f09854
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,34 @@
+# guix-qa-frontpage
+#
+# Copyright © 2022 Christopher Baines <mail@cbaines.net>
+#
+# This file is part of guix-qa-frontpage.
+#
+# guix-qa-frontpage is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 3 of the
+# License, or (at your option) any later version.
+#
+# guix-qa-frontpage is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with the guix-qa-frontpage. If not, see
+# <http://www.gnu.org/licenses/>.
+
+include guile.am
+
+bin_SCRIPTS = \
+ scripts/guix-qa-frontpage
+
+moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir = $(prefix)/lib/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
+assetsdir = $(datadir)/@PACKAGE@
+
+SOURCES = \
+ guix-qa-frontpage/server.scm \
+ guix-qa-frontpage/patchwork.scm \
+ guix-qa-frontpage/view/util.scm \
+ guix-qa-frontpage/view/home.scm