aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-compression.scm')
-rw-r--r--gnu/packages/python-compression.scm103
1 files changed, 102 insertions, 1 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index 691fbd3065..947dd189d3 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -3,11 +3,12 @@
;;; Copyright © 2017, 2019, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2018-2020, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018-2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020, 2022, 2023 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 TakeV <takev@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (gnu packages libffi)
#:use-module (gnu packages compression)
#:use-module (gnu packages crates-io)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages check)
#:use-module (gnu packages maths)
#:use-module (gnu packages pkg-config)
@@ -49,6 +51,50 @@
#:use-module (gnu packages rust-apps)
#:use-module (gnu packages sphinx))
+(define-public python-blosc
+ (package
+ (name "python-blosc")
+ (version "1.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "blosc" version))
+ (sha256
+ (base32
+ "0xmjs28sgpnb940zrhw010dq2m9d8a5h4fgnjyk6645fgfr1j8f2"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (delete-file-recursively "blosc/c-blosc")))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'find-blosc
+ (lambda _
+ (setenv "USE_SYSTEM_BLOSC" "1")
+ (setenv "Blosc_ROOT" #$(this-package-input "c-blosc"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "blosc.test")))))))
+ (propagated-inputs
+ (list python-scikit-build python-numpy))
+ (inputs (list c-blosc))
+ (native-inputs (list cmake-minimal))
+ (home-page "https://github.com/blosc/python-blosc")
+ (synopsis "Python wrapper for the Blosc data compressor library")
+ (description "Blosc is a high performance compressor optimized for binary
+data. It has been designed to transmit data to the processor cache faster
+than the traditional, non-compressed, direct memory fetch approach via a
+@code{memcpy()} system call.
+
+Blosc works well for compressing numerical arrays that contains data with
+relatively low entropy, like sparse data, time series, grids with
+regular-spaced values, etc.
+
+This Python package wraps the Blosc library.")
+ (license license:bsd-3)))
+
(define-public python-multivolumefile
(package
(name "python-multivolumefile")
@@ -151,6 +197,41 @@ following algorithms are available:
@end itemize")
(license license:expat)))
+(define-public python-ewah-bool-utils
+ (package
+ (name "python-ewah-bool-utils")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ewah_bool_utils" version))
+ (sha256
+ (base32 "11z9vv9m19370j762z100dqhy2ndjzkxk3w9z02lzwadbyibal3h"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs
+ (list python-cython python-pytest))
+ (propagated-inputs
+ (list python-numpy))
+ (home-page "https://github.com/yt-project/ewah_bool_utils")
+ (synopsis "EWAH Bool Array compression")
+ (description "This package provide a Python wrapper to @acronym{EWAH,
+ Enhanced Word-Aligned Hybrid} compression bitarray method.")
+ (license (list
+ ;; LICENSE: for Python code.
+ license:bsd-3
+ ;; XXX: Check if it's possible to have it as a dedicated package
+ ;; and link here..
+ ;; ewah_bool_utils/cpp/LICENSE: for C++ bundle, sourced from
+ ;; <https://github.com/lemire/EWAHBoolArray>.
+ license:asl2.0))))
+
(define-public python-pybcj
(package
(name "python-pybcj")
@@ -637,6 +718,26 @@ install: libbitshuffle.so
wrapper. It provides a backport of the @code{Path} object.")
(license license:expat)))
+(define-public python-zipstream-ng
+ (package
+ (name "python-zipstream-ng")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "zipstream-ng" version))
+ (sha256
+ (base32 "1z4zdqqs2rg3z36khgj96bpggv34av337isfv7yxg32prawj687r"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest python-pytest-cov))
+ (home-page "https://github.com/pR0Ps/zipstream-ng")
+ (synopsis "Streamable zip file generator")
+ (description
+ "This package provides a modern and easy to use streamable zip file
+generator")
+ (license license:lgpl3)))
+
(define-public python-zopfli
(package
(name "python-zopfli")