aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5d9e5757a0..b5943f2f47 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5325,18 +5325,15 @@ Accounting.")
(build-system haskell-build-system)
(properties '((upstream-name . "hmatrix")))
(arguments
- `(#:extra-directories ("lapack")))
+ `(#:configure-flags '("--flags=openblas")
+ #:extra-directories ("openblas")))
(inputs
(list ghc-random
ghc-split
ghc-storable-complex
ghc-semigroups
ghc-vector
- ;;("openblas" ,openblas)
- lapack))
- ;; Guix's OpenBLAS is built with the flag "NO_LAPACK=1" which
- ;; disables inclusion of the LAPACK functions.
- ;; (arguments `(#:configure-flags '("--flags=openblas")))
+ openblas))
(home-page "https://github.com/albertoruiz/hmatrix")
(synopsis "Haskell numeric linear algebra library")
(description "The HMatrix package provices a Haskell library for