aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index fc3c2b3e29..89634cf914 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2023 Alex Devaure <ajadevaure@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1571,7 +1572,10 @@ XEv.")
(base32 "0bpix92vzip9vlhzihj3k8h9flrlna231x3y8ah7p4965l177yjd"))))
(build-system meson-build-system)
(native-inputs
- (list pkg-config wayland libxkbcommon))
+ (list pkg-config
+ ;; for wayland-scanner
+ wayland))
+ (inputs (list wayland libxkbcommon))
(synopsis "Xdotool type for Wayland")
(description "Wtype lets you simulate keyboard input and mouse activity,
move and resize windows, etc.")