aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 91c57e0a87..c36279dfa6 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2020 Tom Zander <tomz@freedommail.ch>
;;; Copyright © 2020, 2023 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 ZmnSCPxj jxPCSnmZ <ZmnSCPxj@protonmail.com>
@@ -98,6 +98,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages groff)
#:use-module (gnu packages gsasl)
@@ -147,7 +148,7 @@
;; <https://bitcoincore.org/en/lifecycle/#schedule>.
(package
(name "bitcoin-core")
- (version "26.0")
+ (version "26.1")
(source (origin
(method url-fetch)
(uri
@@ -155,7 +156,7 @@
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "18f0rl7nzr64m54d6hmrphg7z39mmj2ix47kv78n5nr8dqkrj7db"))))
+ "1vimkcm5bd6dyncy6kw16ibkcbykv526ajgh175j0jkvf5fywr4i"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -296,20 +297,20 @@ Accounting.")
(define-public homebank
(package
(name "homebank")
- (version "5.6.6")
+ (version "5.7.4")
(source (origin
(method url-fetch)
- (uri (string-append "http://homebank.free.fr/public/sources/"
- "homebank-" version ".tar.gz"))
+ (uri (string-append "https://www.gethomebank.org/public/sources"
+ "/homebank-" version ".tar.gz"))
(sha256
(base32
- "03nwcpxmsw82gnhy1dialky1d9mfb2jqdzlgc79bxwhlhpqwsvv5"))))
+ "1r2lpf2qjvyc9l4llgy6453dn527pylvd49kr6ihrskmr1373kj2"))))
(build-system glib-or-gtk-build-system)
(native-inputs
(list pkg-config intltool))
(inputs
- (list gtk+ libofx libsoup-minimal-2))
- (home-page "http://homebank.free.fr/")
+ (list gtk+ libofx libsoup-minimal))
+ (home-page "https://gethomebank.org/en/index.php")
(synopsis "Graphical personal accounting application")
(description "HomeBank allows you to manage your personal accounts at
home. The seeks to be lightweight, simple and easy to use. It brings
@@ -688,7 +689,7 @@ blockchain.")
;; the system's dynamically linked library.
(package
(name "monero")
- (version "0.18.3.2")
+ (version "0.18.3.3")
(source
(origin
(method git-fetch)
@@ -706,7 +707,7 @@ blockchain.")
delete-file-recursively
'("external/miniupnp" "external/rapidjson"))))
(sha256
- (base32 "0ri3ss5vgsjk5pzmaaw8yi7sg4lasx58d8kz3m6z5vg7p69gdzxv"))))
+ (base32 "1d3dnkz18v0mlspafnzm301lmdiz6pwjzdbsdq23mn7cyynzgnc9"))))
(build-system cmake-build-system)
(native-inputs
(list doxygen
@@ -793,7 +794,7 @@ the Monero command line client and daemon.")
(define-public monero-gui
(package
(name "monero-gui")
- (version "0.18.3.2")
+ (version "0.18.3.3")
(source
(origin
(method git-fetch)
@@ -809,7 +810,7 @@ the Monero command line client and daemon.")
;; See the 'extract-monero-sources' phase.
(delete-file-recursively "monero")))
(sha256
- (base32 "0jic43b7jzc1i7x2mqqpbbb2992687nm12kk642yr10dm4maklzb"))))
+ (base32 "1yy98y37l5nfxj921h6rbhni6fk0fic9bs4gqbnq2n4397h7jamj"))))
(build-system qt-build-system)
(native-inputs
`(,@(package-native-inputs monero)
@@ -2323,7 +2324,7 @@ and manipulation.")
(define-public xmrig
(package
(name "xmrig")
- (version "6.21.0")
+ (version "6.21.2")
(source
(origin
(method git-fetch)
@@ -2331,7 +2332,7 @@ and manipulation.")
(url "https://github.com/xmrig/xmrig")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (sha256 (base32 "1nmzgwd2r7ra7g4p0s5b77bgh099hf1kisbv4d946c9yiwbdzqgc"))
+ (sha256 (base32 "0rxnrn92v2w9f0zyv4zchilnrc3wa8nw4d4b4isaxx411zxgds6i"))
(modules '((guix build utils)))
(snippet
;; TODO: Try to use system libraries instead of bundled ones in