aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 0820f685b7..0fe1f2c1c7 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -8,7 +8,6 @@
;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
;;; Copyright © 2021, 2022 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,7 +47,6 @@
#:use-module (gnu packages networking)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
- #:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -62,24 +60,22 @@
(define-public python-docker
(package
(name "python-docker")
- (version "7.0.0")
+ (version "5.0.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "docker" version))
(sha256
(base32
- "18z5wzqm7dbxaa5q4gs8yh2dma8i7savqcvibvy1i56djbxkcdrj"))))
+ "1yr7w8vmdis01myx26pqx7wcyz2cy1mfs421alppq3lpc9ms45nr"))))
(build-system python-build-system)
;; TODO: Tests require a running Docker daemon.
(arguments '(#:tests? #f))
(inputs
(list python-requests python-six python-urllib3))
- (native-inputs
- (list python-setuptools-scm))
(propagated-inputs
(list python-docker-pycreds python-paramiko ;adds SSH support
- python-packaging python-websocket-client))
+ python-websocket-client))
(home-page "https://github.com/docker/docker-py/")
(synopsis "Python client for Docker")
(description "Docker-Py is a Python client for the Docker container