diff options
author | Christopher Baines <mail@cbaines.net> | 2019-09-21 12:40:46 +0100 |
---|---|---|
committer | Christopher Baines <mail@cbaines.net> | 2019-09-21 12:40:46 +0100 |
commit | f5ff0f86383031072b0448f7b6d0b1221d5c45f9 (patch) | |
tree | 776ba9af6f7eea789adc69954f43293a4841fee6 | |
parent | ec1b2001cc0e79519fd76729ce0a09b6385dfb2d (diff) | |
download | data-service-f5ff0f86383031072b0448f7b6d0b1221d5c45f9.tar data-service-f5ff0f86383031072b0448f7b6d0b1221d5c45f9.tar.gz |
Hack building a HTML version of the README in to Makefile.am
This is to be able to serve a readable version of the README on the site,
allowing those without Emacs to more easily read it.
-rw-r--r-- | .gitignore | 3 | ||||
-rw-r--r-- | Makefile.am | 9 |
2 files changed, 11 insertions, 1 deletions
@@ -14,6 +14,9 @@ build-aux/missing tests/*.log tests/*.trs +README.html +README.html~ + guix-data-service/config.scm scripts/guix-data-service scripts/guix-data-service-process-job diff --git a/Makefile.am b/Makefile.am index c3176a1..abc430c 100644 --- a/Makefile.am +++ b/Makefile.am @@ -31,10 +31,17 @@ moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION) godir = $(prefix)/lib/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache assetsdir = $(datadir)/@PACKAGE@ -install-data-local: +README.html: README + emacs -q --no-splash -batch -visit README \ + -eval "(progn (require 'org) (let ((org-export-htmlize-output-type 'css)) (org-html-export-to-html nil nil nil t nil)))" + +install-data-local: README.html mkdir -p "$(DESTDIR)$(pkgdatadir)" || exit 1; cp -r assets "$(DESTDIR)$(pkgdatadir)/" || exit 1; cp -r sqitch "$(DESTDIR)$(pkgdatadir)/" || exit 1; + mkdir -p "$(DESTDIR)$(docdir)"; + cp README "$(DESTDIR)$(docdir)/README" + cp README.html "$(DESTDIR)$(docdir)/README.html" install-data-hook: # These files shouldn't be installed, but I have no idea how to specify that |