aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-build.sh
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2021-02-20 17:29:58 -0800
committerChris Marusich <cmmarusich@gmail.com>2021-03-23 23:19:57 -0700
commita16eb6c5f97f136b678540ba61f12b2c08e43e13 (patch)
tree8eefe4fd67d683f8d3fff336441348ef0c5c4283 /tests/guix-build.sh
parentb50f42680352213beb64c248c1af2f9dcc1612fc (diff)
downloadguix-a16eb6c5f97f136b678540ba61f12b2c08e43e13.tar
guix-a16eb6c5f97f136b678540ba61f12b2c08e43e13.tar.gz
Add powerpc64le-linux as a supported Guix architecture.
This makes powerpc64le-linux a supported architecture for Guix, but not for Guix System. * Makefile.am (SUPPORTED_SYSTEMS): Add an entry for powerpc64le-linux. * etc/guix-install.sh (chk_sys_arch): Same. * guix/packages.scm (%supported-systems): Same. * m4/guix.m4 (GUIX_ASSERT_SUPPORTED_SYSTEM): Same. * tests/guix-build.sh (all_systems): Same.
Diffstat (limited to 'tests/guix-build.sh')
-rw-r--r--tests/guix-build.sh6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/guix-build.sh b/tests/guix-build.sh
index b7602e668c..e20702c521 100644
--- a/tests/guix-build.sh
+++ b/tests/guix-build.sh
@@ -1,6 +1,7 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012, 2013, 2014, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+# Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
#
# This file is part of GNU Guix.
#
@@ -61,8 +62,9 @@ guix build -e '(@@ (gnu packages bootstrap) %bootstrap-guile)'
test `guix build sed -s x86_64-linux -d | wc -l` = 1
# Passing multiple '-s' flags.
-all_systems="-s x86_64-linux -s i686-linux -s armhf-linux -s aarch64-linux"
-test `guix build sed $all_systems -d | sort -u | wc -l` = 4
+all_systems="-s x86_64-linux -s i686-linux -s armhf-linux -s aarch64-linux \
+-s powerpc64le-linux"
+test `guix build sed $all_systems -d | sort -u | wc -l` = 5
# Check there's no weird memoization effect leading to erroneous results.
# See <https://bugs.gnu.org/40482>.