aboutsummaryrefslogtreecommitdiff
path: root/guix/profiles.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-10 09:40:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:02 +0200
commit36d7acf003f14af2203f4a35cdf2a9801cb1c672 (patch)
treec08733715012ad279fcad135b338303355d5b3f7 /guix/profiles.scm
parentf1b21bcfb1c024a2830d3e2817970bd9056a7756 (diff)
downloadguix-36d7acf003f14af2203f4a35cdf2a9801cb1c672.tar
guix-36d7acf003f14af2203f4a35cdf2a9801cb1c672.tar.gz
gnu: Deprecate texlive-base in favor of texlive-scheme-basic.
* gnu/packages/tex.scm (texlive-base): Deprecate variable. (texlive-updmap.cfg): Use default packages from now deprecated TEXLIVE-BASE. Also remove already implemented TODO. * doc/build.scm (pdf-manual): * gnu/packages/statistics.scm: Replace TEXLIVE-BASE with call to TEXLIVE-UPDMAP.CFG. * guix/profiles.scm (texlive-font-maps): Trigger TeX Live hook whenever a texlive package is included in the manifest.
Diffstat (limited to 'guix/profiles.scm')
-rw-r--r--guix/profiles.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/profiles.scm b/guix/profiles.scm
index 6467e464c8..05fa5fa862 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -1868,8 +1868,8 @@ MANIFEST."
(invoke mktexlsr b)
(install-file (string-append b "/ls-R") a))))))
- (mlet %store-monad ((texlive-base (manifest-lookup-package manifest "texlive-base")))
- (if (and texlive-base (pair? texlive-inputs))
+ (with-monad %store-monad
+ (if (pair? texlive-inputs)
(gexp->derivation "texlive-font-maps" build
#:substitutable? #f
#:local-build? #t