aboutsummaryrefslogtreecommitdiff
path: root/guix/lint.scm
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-20 21:25:41 -0700
committerLudovic Courtès <ludo@gnu.org>2023-03-27 18:48:53 +0200
commitc9af27d4ca733b20f09019f1465d3e5fdc1ec724 (patch)
tree00d781a58b7df2919d857d9f77cce7bd59fe1f74 /guix/lint.scm
parent38e7813c0358a829616c1748c975d1ebf709258d (diff)
downloadguix-c9af27d4ca733b20f09019f1465d3e5fdc1ec724.tar
guix-c9af27d4ca733b20f09019f1465d3e5fdc1ec724.tar.gz
lint: Append "/info/refs" to git-reference-url.
For the atftp package added in the preceeding commit, lint produced this warning: gnu/packages/networking.scm:2924:5: atftp@0.8.0: URI https://git.code.sf.net/p/atftp/code not reachable: 404 ("Not Found") Thanks to Sergey Trofimov for suggesting a fix! [1] [1] https://issues.guix.gnu.org/62156#3 It was implemented here, and the warning disappeared. * guix/lint.scm (check-source): Append "/info/refs" to git-reference-url. Co-authored-by: Sergey Trofimov <sarg@sarg.org.ru> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/lint.scm')
-rw-r--r--guix/lint.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/guix/lint.scm b/guix/lint.scm
index 9eece374ff..3a93ba5325 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -1224,7 +1224,14 @@ password, provided REF's URI is HTTP or HTTPS."
'())))
((git-reference? (origin-uri origin))
(warnings-for-uris
- (list (string->uri (git-reference-url (origin-uri origin))))))
+ ;; for atftp, lint produced a warning:
+ ;; gnu/packages/networking.scm:2924:5: atftp@0.8.0:
+ ;; URI https://git.code.sf.net/p/atftp/code not reachable:
+ ;; 404 ("Not Found")
+ ;; fix from here: https://issues.guix.gnu.org/62156#3
+ (list (string->uri (string-append
+ (git-reference-url (origin-uri origin))
+ "/info/refs")))))
((or (svn-reference? (origin-uri origin))
(svn-multi-reference? (origin-uri origin)))
(let ((uri (svn-reference-uri-with-userinfo (origin-uri origin))))