aboutsummaryrefslogtreecommitdiff
path: root/guix/hash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-08-31 17:07:07 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-04 17:25:11 +0200
commitca719424455465fca4b872c371daf2a46de88b33 (patch)
treece967f28949e46ddc864bb5d43a380fd7c9e0c0d /guix/hash.scm
parent7e1d229019c1924a2748e5daec2a619e7efbd7d7 (diff)
downloadguix-ca719424455465fca4b872c371daf2a46de88b33.tar
guix-ca719424455465fca4b872c371daf2a46de88b33.tar.gz
Switch to Guile-Gcrypt.
This removes (guix hash) and (guix pk-crypto), which now live as part of Guile-Gcrypt (version 0.1.0.) * guix/gcrypt.scm, guix/hash.scm, guix/pk-crypto.scm, tests/hash.scm, tests/pk-crypto.scm: Remove. * configure.ac: Test for Guile-Gcrypt. Remove LIBGCRYPT and LIBGCRYPT_LIBDIR assignments. * m4/guix.m4 (GUIX_ASSERT_LIBGCRYPT_USABLE): Remove. * README: Add Guile-Gcrypt to the dependencies; move libgcrypt as "required unless --disable-daemon". * doc/guix.texi (Requirements): Likewise. * gnu/packages/bash.scm, guix/derivations.scm, guix/docker.scm, guix/git.scm, guix/http-client.scm, guix/import/cpan.scm, guix/import/cran.scm, guix/import/crate.scm, guix/import/elpa.scm, guix/import/gnu.scm, guix/import/hackage.scm, guix/import/texlive.scm, guix/import/utils.scm, guix/nar.scm, guix/pki.scm, guix/scripts/archive.scm, guix/scripts/authenticate.scm, guix/scripts/download.scm, guix/scripts/hash.scm, guix/scripts/pack.scm, guix/scripts/publish.scm, guix/scripts/refresh.scm, guix/scripts/substitute.scm, guix/store.scm, guix/store/deduplication.scm, guix/tests.scm, tests/base32.scm, tests/builders.scm, tests/challenge.scm, tests/cpan.scm, tests/crate.scm, tests/derivations.scm, tests/gem.scm, tests/nar.scm, tests/opam.scm, tests/pki.scm, tests/publish.scm, tests/pypi.scm, tests/store-deduplication.scm, tests/store.scm, tests/substitute.scm: Adjust imports. * gnu/system/vm.scm: Likewise. (guile-sqlite3&co): Rename to... (gcrypt-sqlite3&co): ... this. Add GUILE-GCRYPT. (expression->derivation-in-linux-vm)[config]: Remove. (iso9660-image)[config]: Remove. (qemu-image)[config]: Remove. (system-docker-image)[config]: Remove. * guix/scripts/pack.scm: Adjust imports. (guile-sqlite3&co): Rename to... (gcrypt-sqlite3&co): ... this. Add GUILE-GCRYPT. (self-contained-tarball)[build]: Call 'make-config.scm' without #:libgcrypt argument. (squashfs-image)[libgcrypt]: Remove. [build]: Call 'make-config.scm' without #:libgcrypt. (docker-image)[config, json]: Remove. [build]: Add GUILE-GCRYPT to the extensions Remove (guix config) from the imported modules. * guix/self.scm (specification->package): Remove "libgcrypt", add "guile-gcrypt". (compiled-guix): Remove #:libgcrypt. [guile-gcrypt]: New variable. [dependencies]: Add it. [*core-modules*]: Remove #:libgcrypt from 'make-config.scm' call. Add #:extensions. [*config*]: Remove #:libgcrypt from 'make-config.scm' call. (%dependency-variables): Remove %libgcrypt. (make-config.scm): Remove #:libgcrypt. * build-aux/build-self.scm (guile-gcrypt): New variable. (make-config.scm): Remove #:libgcrypt. (build-program)[fake-gcrypt-hash]: New variable. Add (gcrypt hash) to the imported modules. Adjust load path assignments. * gnu/packages/package-management.scm (guix)[propagated-inputs]: Add GUILE-GCRYPT. [arguments]: In 'wrap-program' phase, add GUILE-GCRYPT to the search path.
Diffstat (limited to 'guix/hash.scm')
-rw-r--r--guix/hash.scm184
1 files changed, 0 insertions, 184 deletions
diff --git a/guix/hash.scm b/guix/hash.scm
deleted file mode 100644
index 8d7ba21425..0000000000
--- a/guix/hash.scm
+++ /dev/null
@@ -1,184 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (guix hash)
- #:use-module (guix gcrypt)
- #:use-module (rnrs bytevectors)
- #:use-module (ice-9 binary-ports)
- #:use-module (system foreign)
- #:use-module ((guix build utils) #:select (dump-port))
- #:use-module (srfi srfi-11)
- #:use-module (srfi srfi-26)
- #:export (sha1
- sha256
- open-sha256-port
- port-sha256
- file-sha256
- open-sha256-input-port))
-
-;;; Commentary:
-;;;
-;;; Cryptographic hashes.
-;;;
-;;; Code:
-
-
-;;;
-;;; Hash.
-;;;
-
-(define-syntax GCRY_MD_SHA256
- ;; Value as of Libgcrypt 1.5.2.
- (identifier-syntax 8))
-
-(define-syntax GCRY_MD_SHA1
- (identifier-syntax 2))
-
-(define bytevector-hash
- (let ((hash (pointer->procedure void
- (libgcrypt-func "gcry_md_hash_buffer")
- `(,int * * ,size_t))))
- (lambda (bv type size)
- "Return the hash TYPE, of SIZE bytes, of BV as a bytevector."
- (let ((digest (make-bytevector size)))
- (hash type (bytevector->pointer digest)
- (bytevector->pointer bv) (bytevector-length bv))
- digest))))
-
-(define sha1
- (cut bytevector-hash <> GCRY_MD_SHA1 20))
-
-(define sha256
- (cut bytevector-hash <> GCRY_MD_SHA256 (/ 256 8)))
-
-(define open-sha256-md
- (let ((open (pointer->procedure int
- (libgcrypt-func "gcry_md_open")
- `(* ,int ,unsigned-int))))
- (lambda ()
- (let* ((md (bytevector->pointer (make-bytevector (sizeof '*))))
- (err (open md GCRY_MD_SHA256 0)))
- (if (zero? err)
- (dereference-pointer md)
- (throw 'gcrypt-error err))))))
-
-(define md-write
- (pointer->procedure void
- (libgcrypt-func "gcry_md_write")
- `(* * ,size_t)))
-
-(define md-read
- (pointer->procedure '*
- (libgcrypt-func "gcry_md_read")
- `(* ,int)))
-
-(define md-close
- (pointer->procedure void
- (libgcrypt-func "gcry_md_close")
- '(*)))
-
-
-(define (open-sha256-port)
- "Return two values: an output port, and a thunk. When the thunk is called,
-it returns the SHA256 hash (a bytevector) of all the data written to the
-output port."
- (define sha256-md
- (open-sha256-md))
-
- (define digest #f)
- (define position 0)
-
- (define (finalize!)
- (let ((ptr (md-read sha256-md 0)))
- (set! digest (bytevector-copy (pointer->bytevector ptr 32)))
- (md-close sha256-md)))
-
- (define (write! bv offset len)
- (if (zero? len)
- (begin
- (finalize!)
- 0)
- (let ((ptr (bytevector->pointer bv offset)))
- (md-write sha256-md ptr len)
- (set! position (+ position len))
- len)))
-
- (define (get-position)
- position)
-
- (define (close)
- (unless digest
- (finalize!)))
-
- (values (make-custom-binary-output-port "sha256"
- write! get-position #f
- close)
- (lambda ()
- (unless digest
- (finalize!))
- digest)))
-
-(define (port-sha256 port)
- "Return the SHA256 hash (a bytevector) of all the data drained from PORT."
- (let-values (((out get)
- (open-sha256-port)))
- (dump-port port out)
- (close-port out)
- (get)))
-
-(define (file-sha256 file)
- "Return the SHA256 hash (a bytevector) of FILE."
- (call-with-input-file file port-sha256))
-
-(define (open-sha256-input-port port)
- "Return an input port that wraps PORT and a thunk to get the hash of all the
-data read from PORT. The thunk always returns the same value."
- (define md
- (open-sha256-md))
-
- (define (read! bv start count)
- (let ((n (get-bytevector-n! port bv start count)))
- (if (eof-object? n)
- 0
- (begin
- (unless digest
- (let ((ptr (bytevector->pointer bv start)))
- (md-write md ptr n)))
- n))))
-
- (define digest #f)
-
- (define (finalize!)
- (let ((ptr (md-read md 0)))
- (set! digest (bytevector-copy (pointer->bytevector ptr 32)))
- (md-close md)))
-
- (define (get-hash)
- (unless digest
- (finalize!))
- digest)
-
- (define (unbuffered port)
- ;; Guile <= 2.0.9 does not support 'setvbuf' on custom binary input ports.
- (setvbuf port _IONBF)
- port)
-
- (values (unbuffered (make-custom-binary-input-port "sha256" read! #f #f #f))
- get-hash))
-
-;;; hash.scm ends here