aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-25 19:29:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-03-26 08:07:52 +0200
commit25802a183a4d0cc6be5fe402b455cf19eae27a93 (patch)
tree94941a64b87a70702d406557aec23896e673e7fe /gnu
parent08e5a52a7f878d821afb1420b0a76f141e380c24 (diff)
downloadguix-25802a183a4d0cc6be5fe402b455cf19eae27a93.tar
guix-25802a183a4d0cc6be5fe402b455cf19eae27a93.tar.gz
gnu: Add zxcvbn-c.
* gnu/packages/password-utils.scm (zxcvbn-c): New variable. Change-Id: I160575fb4b7ce9fe7a5bd5bb5322c78376f8d259
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/password-utils.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 97561316f6..1dbf138ad4 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
-;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2016 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
@@ -1429,6 +1429,43 @@ function. Since they all work with @code{STDIN} and @code{STDOUT} you can
group them into chains.")
(license license:expat)))
+(define-public zxcvbn-c
+ (package
+ (name "zxcvbn-c")
+ (version "2.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tsyrogit/zxcvbn-c")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1clm9sxz6q360xk6vq5hi3b0mq374nl958mjcfxk94l692zrpaj4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "CXX=" #$(cxx-for-target)))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "zxcvbn.h" (string-append #$output "/include"))
+ (for-each (lambda (file)
+ (install-file file
+ (string-append #$output "/lib")))
+ (find-files "." "libzxcvbn\\.so.*")))))))
+ (home-page "https://github.com/tsyrogit/zxcvbn-c")
+ (synopsis "C/C++ implementation of the zxcvbn password strength estimation")
+ (description "This library is a C/C++ implementation of the zxcvbn password
+strength estimator. It provides functions to rate password strength, by
+comparing the password to several word lists, including English first and last
+names.")
+ (license license:expat)))
+
(define-public hydra
(package
(name "hydra")