aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-04-28 19:45:13 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-08 00:05:05 +0100
commit231ffaf1ac3228ae89b919d0685aed8b10bd2358 (patch)
treee312dd056d4f38df4e5ce26bb28433d9a2147afc /gnu
parent6f60f90c15c465fcdd83b77bf27f0f3ffd980008 (diff)
downloadguix-231ffaf1ac3228ae89b919d0685aed8b10bd2358.tar
guix-231ffaf1ac3228ae89b919d0685aed8b10bd2358.tar.gz
gnu: Add go-github-com-ipfs-go-cidutil.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-cidutil): New variable. Change-Id: I6077fc00d22b541a959a6623c8666c35288ca105 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ipfs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 526de1c8c3..98d2670f95 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -67,6 +67,36 @@
used in @code{go-ipfs} and related packages to refer to a typed hunk of data.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-cidutil
+ (package
+ (name "go-github-com-ipfs-go-cidutil")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-cidutil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j18wf42rfxrrh2fjdbjsjvjqxwgvg46b9wl6y5ig22fx5hvpm1n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipfs/go-cidutil"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-cid
+ go-github-com-multiformats-go-multibase
+ go-github-com-multiformats-go-multicodec
+ go-github-com-multiformats-go-multihash))
+ (home-page "https://github.com/ipfs/go-cidutil")
+ (synopsis "Utility functions and types for working with CIDs")
+ (description
+ "@code{go-cidutil} implements various utilities and helper functions for working
+with @url{https://github.com/ipld/cid, CIDs}.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipfs-cmdkit-files
(let ((commit
"386fcf8f18a185ec121676665fe2d9574496048d")