aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJesse Eisses <jesse@eisses.email>2024-04-26 10:01:53 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 15:38:27 +0100
commitd12456bebdfef964fef36c63d9b44677f4e3d8f4 (patch)
tree9b1e20620cf1d3a5a5b443a69505e87be3e336c5 /gnu/packages
parent223c531ec490e23fc83ba008eb8bffed709c832a (diff)
downloadguix-d12456bebdfef964fef36c63d9b44677f4e3d8f4.tar
guix-d12456bebdfef964fef36c63d9b44677f4e3d8f4.tar.gz
gnu: Add go-github-com-sherclockholmes-webpush-go.
* gnu/packages/golang-web.scm (go-github-com-sherclockholmes-webpush-go): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ida07915e1659b79353dd267991bcb615ee5cc837
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c5c3efb7c5..f2a83226d4 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1715,6 +1716,33 @@ protocol.")
(define-public go-github-com-lucas-clemente-quic-go
(deprecated-package "go-github-com-lucas-clemente-quic-go" go-github-com-quic-go-quic-go))
+(define-public go-github-com-sherclockholmes-webpush-go
+ (package
+ (name "go-github-com-sherclockholmes-webpush-go")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SherClockHolmes/webpush-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qv16zvkd1c7q81v2ai8pfz590fxdrk4lfbgyymln0q7jn5wlvki"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/SherClockHolmes/webpush-go"))
+ (propagated-inputs
+ (list go-github-com-golang-jwt-jwt go-golang-org-x-crypto))
+ (home-page "https://github.com/SherClockHolmes/webpush-go")
+ (synopsis "Web Push API Encryption with VAPID support")
+ (description
+ "Web Push API Encryption with
+@url{https://datatracker.ietf.org/doc/html/draft-ietf-webpush-vapid-01, VAPID}
+support.")
+ (license license:expat)))
+
(define-public go-github-com-sourcegraph-jsonrpc2
(package
(name "go-github-com-sourcegraph-jsonrpc2")