aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJesse Eisses <jesse@eisses.email>2024-04-26 00:08:19 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 15:38:28 +0100
commitbb1beff54d1f16c4c38156cec4712b417faa763f (patch)
treed61af66941753157a0c81b6b79f86d22a4cf534a /gnu/packages
parent2799f6c6e1b542fbf7756326ddd05ff5352b2001 (diff)
downloadguix-bb1beff54d1f16c4c38156cec4712b417faa763f.tar
guix-bb1beff54d1f16c4c38156cec4712b417faa763f.tar.gz
gnu: Add go-git-sr-ht-sircmpwn-go-bare.
* gnu/packages/golang-xyz.scm (go-git-sr-ht-sircmpwn-go-bare): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Iea3ac2489549fe4cb1b1ce216a998c30c9f996d6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 00243753fd..377488892f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -113,6 +113,35 @@
a human-readable byte format.")
(license license:asl2.0)))
+(define-public go-git-sr-ht-sircmpwn-go-bare
+ (package
+ (name "go-git-sr-ht-sircmpwn-go-bare")
+ (version "0.0.0-20210406120253-ab86bc2846d9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/go-bare")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zh36qppk8lscd8mysy0anm2vw5c74c10f4qvhd541wxm06di928"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "git.sr.ht/~sircmpwn/go-bare"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-git-sr-ht-sircmpwn-getopt))
+ (home-page "https://git.sr.ht/~sircmpwn/go-bare")
+ (synopsis "Implementation of the BARE message format")
+ (description
+ "This package provides an implementation of the @acronym{BARE, Binary
+Application Record Encoding} https://baremessages.org/ message format for
+Golang.")
+ (license license:asl2.0)))
+
(define-public go-github-com-a8m-envsubst
(package
(name "go-github-com-a8m-envsubst")