aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJesse Eisses <jesse@eisses.email>2024-04-26 10:01:52 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 15:38:28 +0100
commitb7800aa34fe986b662d858a7799dcf14df102645 (patch)
tree75f53318a94d5e851af3fc589d7208f74f7d1fa1 /gnu/packages
parent881f9630c99e1aeeb7d539a58ac8fff4bf7a12a7 (diff)
downloadguix-b7800aa34fe986b662d858a7799dcf14df102645.tar
guix-b7800aa34fe986b662d858a7799dcf14df102645.tar.gz
gnu: go-github-com-prometheus-client-model: Update to 0.5.0.
* gnu/packages/golang.scm (go-github-com-prometheus-client-model): Update to 0.5.0. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Iebb57390b99a4ed2567588872a9745a69aae9ced
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm54
1 files changed, 26 insertions, 28 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 865d422d4e..f0e31ed732 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2877,34 +2877,32 @@ on top of the standard library @code{flag} package.")
(license license:bsd-3)))
(define-public go-github-com-prometheus-client-model
- (let ((commit "14fe0d1b01d4d5fc031dd4bec1823bd3ebbe8016")
- (revision "2"))
- (package
- (name "go-github-com-prometheus-client-model")
- (version (git-version "0.0.2" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/client_model")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0zdmk6rbbx39cvfz0r59v2jg5sg9yd02b4pds5n5llgvivi99550"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/client_model"
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (propagated-inputs
- (list go-github-com-golang-protobuf-proto))
- (synopsis "Data model artifacts for Prometheus")
- (description "This package provides data model artifacts for Prometheus.")
- (home-page "https://github.com/prometheus/client_model")
- (license license:asl2.0))))
+ (package
+ (name "go-github-com-prometheus-client-model")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/client_model")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pl9i969jx5vkhm8vd5vb8yrifv37aw6h8mjg04820pw0ygfbigy"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/client_model"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (propagated-inputs
+ (list go-github-com-golang-protobuf-proto))
+ (synopsis "Data model artifacts for Prometheus")
+ (description "This package provides data model artifacts for Prometheus.")
+ (home-page "https://github.com/prometheus/client_model")
+ (license license:asl2.0)))
(define-public go-github-com-rcrowley-go-metrics
(let ((commit "cac0b30c2563378d434b5af411844adff8e32960")