aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-04-28 19:45:10 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 23:51:25 +0100
commit8cb146a3e6d4d984b2fdff13a245a3bd796bf707 (patch)
treeb158b1bc4495e4210be93f9315c5bbf0bd9aa38d /gnu/packages
parentf669a24a95b6042849a29812bc7abe81b5685bd4 (diff)
downloadguix-8cb146a3e6d4d984b2fdff13a245a3bd796bf707.tar
guix-8cb146a3e6d4d984b2fdff13a245a3bd796bf707.tar.gz
gnu: Add go-github-com-ipfs-go-detect-race.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-detect-race): New variable. Change-Id: Ic65c12a717a50c4309bc89d29d158a43fbc0c81a Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ipfs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 4329f0a4e3..9e40b45637 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -96,6 +96,29 @@ that are shared between @command{go-ipfs/commands} and its rewrite
@command{go-ipfs-cmds}.")
(license license:expat))))
+(define-public go-github-com-ipfs-go-detect-race
+ (package
+ (name "go-github-com-ipfs-go-detect-race")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-detect-race")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rqb0q66d7z852j5mhlr025dz698c44w014g4mx587amr1rvwqna"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipfs/go-log/v2"))
+ (home-page "https://github.com/ipfs/go-detect-race")
+ (synopsis "Detect if compiled with race")
+ (description "Check if the race detector is running.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipfs-util
(package
(name "go-github-com-ipfs-go-ipfs-util")