aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 23:13:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 23:18:48 +0100
commit1f6c4f226d6b1fb008a7cb847f3cdb39f07ec027 (patch)
treeb6ed5c4fa7e7c54c0e965370b8e296153de4a18b /gnu/packages
parent330a133b856bd85cf77734714ebd1bd5471e4e7d (diff)
downloadguix-1f6c4f226d6b1fb008a7cb847f3cdb39f07ec027.tar
guix-1f6c4f226d6b1fb008a7cb847f3cdb39f07ec027.tar.gz
gnu: Add go-bazil-org-fuse.
* gnu/packages/golang-xyz.scm (go-bazil-org-fuse): New variable. Change-Id: I933d90dca50110f53831febc81d587c14973934f
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1808ae154c..cd023da86c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-compression)
#:use-module (gnu packages golang-crypto)
+ #:use-module (gnu packages golang-web)
#:use-module (gnu packages linux)
#:use-module (gnu packages specifications))
@@ -83,6 +84,36 @@
;;; Libraries:
;;;
+(define-public go-bazil-org-fuse
+ (package
+ (name "go-bazil-org-fuse")
+ (version "0.0.0-20200117225306-7b5117fecadc")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bazil/fuse")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bw2lp1nijpqp729k808xkhwmb8nn7igsv51hvv9jw74q805qg2f"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Tests require root access to mount file system.
+ #:tests? #f
+ #:go go-1.19
+ #:import-path "bazil.org/fuse"))
+ (propagated-inputs
+ (list go-github-com-tv42-httpunix go-golang-org-x-sys))
+ (home-page "https://bazil.org/fuse")
+ (synopsis "FUSE filesystems in Golang")
+ (description
+ "Package fuse enables writing FUSE file systems. It is a from-scratch
+implementation of the kernel-userspace communication protocol, and does not
+use the C library from the project called FUSE.")
+ (license (list license:bsd-2 license:bsd-3 license:hpnd))))
+
(define-public go-code-cloudfoundry-org-bytefmt
(package
(name "go-code-cloudfoundry-org-bytefmt")