aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 22:19:35 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 23:18:47 +0100
commit072b06f2f3751b493c8401b666a71618f3e937e6 (patch)
tree5dca31807aeb9d7dd5f4a16a6df912aa25a240be /gnu/packages
parent9716914d4e4c1ba1cb99c3ed2b36b3cbf5ed14cd (diff)
downloadguix-072b06f2f3751b493c8401b666a71618f3e937e6.tar
guix-072b06f2f3751b493c8401b666a71618f3e937e6.tar.gz
gnu: go-git-sr-ht-sircmpwn-getopt: Move to golang-xyz.
* gnu/packages/golang.scm (go-git-sr-ht-sircmpwn-getopt): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ic53ec6828f7389326191b659dd16b623e6d1af43
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7c255ceb53..2ebb1251e0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 raingloom <raingloom@riseup.net>
;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
@@ -32,9 +33,9 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
-;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -155,6 +156,31 @@ a human-readable byte format.")
search functionality to database applications.")
(license license:expat)))
+(define-public go-git-sr-ht-sircmpwn-getopt
+ (package
+ (name "go-git-sr-ht-sircmpwn-getopt")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/getopt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f9rammnmhaz21qkmz7qf76r8jlzi323g05ps3j7gwrxlw7442a6"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~sircmpwn/getopt"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://git.sr.ht/~sircmpwn/getopt")
+ (synopsis "POSIX getopt for Go")
+ (description
+ "This package provides a POSIX-compatible implementation of
+@code{getopt} for Go.")
+ (license license:bsd-3)))
+
(define-public go-git-sr-ht-sircmpwn-go-bare
(package
(name "go-git-sr-ht-sircmpwn-go-bare")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3d119b4221..e9fbcf70e0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8402,30 +8402,6 @@ provides an API similar to that of NET/HTTP to facilitate the development of
Gemini clients and servers.")
(license license:expat)))
-(define-public go-git-sr-ht-sircmpwn-getopt
- (package
- (name "go-git-sr-ht-sircmpwn-getopt")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~sircmpwn/getopt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0f9rammnmhaz21qkmz7qf76r8jlzi323g05ps3j7gwrxlw7442a6"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "git.sr.ht/~sircmpwn/getopt"))
- (propagated-inputs (list go-github-com-stretchr-testify))
- (home-page "https://git.sr.ht/~sircmpwn/getopt")
- (synopsis "POSIX getopt for Go")
- (description
- "This package provides a POSIX-compatible implementation of
-@code{getopt} for Go.")
- (license license:bsd-3)))
-
(define-public gofumpt
(package
(name "gofumpt")