aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 16:02:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-24 19:15:30 +0200
commitc0f3c0cfd9723baf743bb552b603f37abfd2af96 (patch)
tree427a9e18404d4164834a4077d0d323f10a1864a9 /gnu/packages/cpp.scm
parent3643389ba7777fff205d31d38531ae68c93fc5a7 (diff)
downloadguix-c0f3c0cfd9723baf743bb552b603f37abfd2af96.tar
guix-c0f3c0cfd9723baf743bb552b603f37abfd2af96.tar.gz
gnu: range-v3: Format with 'guix style'.
* gnu/packages/cpp.scm (range-v3): Format with 'guix style'. Change-Id: I249443e5e5d0f7ef49e33de4f140246a862101d2
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm43
1 files changed, 19 insertions, 24 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index dd16c53fce..eeb4e6bf7b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -191,41 +191,36 @@ development effort.")
(source
(origin
(method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/ericniebler/range-v3.git")
- (commit version)))
- (file-name
- (git-file-name name version))
+ (uri (git-reference
+ (url "https://github.com/ericniebler/range-v3.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(patches (search-patches "range-v3-build-with-gcc10.patch"))
(sha256
(base32 "18230bg4rq9pmm5f8f65j444jpq56rld4fhmpham8q3vr1c1bdjh"))))
(build-system cmake-build-system)
(arguments
(list
- #:configure-flags
- #~(list "-DRANGES_NATIVE=OFF")))
- (native-inputs
- (list doxygen perl))
- (inputs
- (list boost))
+ #:configure-flags #~(list "-DRANGES_NATIVE=OFF")))
+ (native-inputs (list doxygen perl))
+ (inputs (list boost))
(synopsis "Range library for C++14/17/20")
- (description "Range-v3 is an extension of the Standard Template Library that
+ (description
+ "Range-v3 is an extension of the Standard Template Library that
makes its iterators and algorithms more powerful by making them composable.
Unlike other range-like solutions which, seek to do away with iterators, in
range-v3 ranges are an abstraction layer on top of iterators.")
(home-page "https://github.com/ericniebler/range-v3/")
- (license
- (list
- ;; Elements of Programming
- (license:x11-style "file:///LICENSE.txt")
- ;; SGI STL
- license:sgifreeb2.0
-;;; LibC++ (dual-licensed)
- license:expat
- license:ncsa
- ;; Others
- license:boost1.0))))
+ (license (list
+ ;; Elements of Programming
+ (license:x11-style "file:///LICENSE.txt")
+ ;; SGI STL
+ license:sgifreeb2.0
+ ;; LibC++ (dual-licensed)
+ license:expat
+ license:ncsa
+ ;; Others
+ license:boost1.0))))
(define-public robin-hood-hashing
(package