aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-05 23:43:44 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-09 22:10:11 -0500
commit0ec349078f49a1ef621b709fe08c7fd21aee5755 (patch)
treea6db63adf905b3f8606e7f7fa34fa2ed52143a4f /gnu/packages/cpp.scm
parent45d07a0b01c30d18a537c47efce79192b8c8d178 (diff)
downloadguix-0ec349078f49a1ef621b709fe08c7fd21aee5755.tar
guix-0ec349078f49a1ef621b709fe08c7fd21aee5755.tar.gz
gnu: Add expected-lite.
* gnu/packages/cpp.scm (expected-lite): New variable. Change-Id: I5a21dd631e1f2a3c97b920efcdca69f2537b42da
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 0f2c6e0b85..f65506dcec 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2022, 2023 David Elsing <david.elsing@posteo.net>
;;; Copyright © 2022, 2023 Zheng Junjie <873216071@qq.com>
-;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 Sughosha <Sughosha@proton.me>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -327,6 +327,28 @@ the @code{Clang/LLVM} infrastructure to extract the data, and emits it in
various formats, including @code{json}.")
(license license:gpl2+)))
+(define-public expected-lite
+ (package
+ (name "expected-lite")
+ (version "0.6.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/martinmoene/expected-lite")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d58nqh2fwdzdpln2wlnf898wyfxdnskq6ff33azbg92d5ibzys2"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/martinmoene/expected-lite")
+ (synopsis "Expected objects in C++11 and later")
+ (description "@i{expected lite} is a single-file header-only library for
+objects that either represent a valid value or an error that can be passed by
+value. It is intended for use with C++11 and later. The library is based on
+the @code{std::expected} proposal (@url{http://wg21.link/p0323}).")
+ (license license:boost1.0)))
+
(define-public libzen
(package
(name "libzen")