aboutsummaryrefslogtreecommitdiff
path: root/etc/kernels-manifest.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-12-27 21:23:32 -0500
committerLeo Famulari <leo@famulari.name>2022-12-29 13:51:58 -0500
commitd07d6ea31a883d395d692483d84e7797b4c2ce0f (patch)
treeed7e27fe4da103a81bd351b06bab598ca4fae900 /etc/kernels-manifest.scm
parent77d4bff94c6918eb0c0ccd20ee610e6dfc823aec (diff)
downloadguix-d07d6ea31a883d395d692483d84e7797b4c2ce0f.tar
guix-d07d6ea31a883d395d692483d84e7797b4c2ce0f.tar.gz
maint: Add a manifest for everything related to linux-libre.
* etc/kernels-manifest.scm: New file. * Makefile.am (EXTRA_DIST): Add it.
Diffstat (limited to 'etc/kernels-manifest.scm')
-rw-r--r--etc/kernels-manifest.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/etc/kernels-manifest.scm b/etc/kernels-manifest.scm
new file mode 100644
index 0000000000..6da7e374c5
--- /dev/null
+++ b/etc/kernels-manifest.scm
@@ -0,0 +1,33 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Leo Famulari <leo@famulari.name>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;;; This file returns a manifest of packages related to linux-libre.
+;;; Simplistically, it selects packages whose names begin with "linux-libre".
+;;; It is used to assist continuous integration of the kernel packages.
+
+(use-modules (guix packages))
+
+(manifest
+ (map package->manifest-entry
+ (fold-packages
+ (lambda (package lst)
+ (if (string-prefix? "linux-libre"
+ (package-name package))
+ (cons package lst)
+ lst))
+ '())))