aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-03 21:15:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:12 +0100
commitfbece5a8e0f55d00c91edf082d01e1f9778a0913 (patch)
tree045e39c261471ea1c934222c221c5f78092b1c50
parent310e0c7165d1fa006600417301c3c54ef5a5a3e8 (diff)
downloadguix-fbece5a8e0f55d00c91edf082d01e1f9778a0913.tar
guix-fbece5a8e0f55d00c91edf082d01e1f9778a0913.tar.gz
gnu: Add python-assay.
* gnu/packages/python-check.scm (python-assay): New variable. Change-Id: I0ec910d8c37000ff08119a33e3f42af2269fa494
-rw-r--r--gnu/packages/python-check.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 777791cb6c..6fdfaad6fb 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2021-2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021-2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
@@ -61,6 +61,38 @@
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public python-assay
+ ;; No release yet.
+ (let ((commit "74617d70e77afa09f58b3169cf496679ac5d5621")
+ (revision "0"))
+ (package
+ (name "python-assay")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brandon-rhodes/assay")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1klxmamj88mn0q348r08zksccgsbch8sp0m4b04s3myrqnslp2nd"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "-m" "assay.tests")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (when tests?
+ (apply invoke "python" test-flags)))))))
+ (home-page "https://github.com/brandon-rhodes/assay")
+ (synopsis "Python testing framework")
+ (description
+ "This package provides opiniotated Python test framework prototype.")
+ (license license:expat))))
+
(define-public python-assertpy
(package
(name "python-assertpy")