aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-10 22:51:59 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-10 23:00:43 +0100
commitfbc5e7fc40919a66a24855430f7b32a304579d0d (patch)
treef0f7b71955229289d8adafc3f62e46626386cb5c
parent376d957291ba21bb500b252493d53253ddc4a165 (diff)
downloadguix-fbc5e7fc40919a66a24855430f7b32a304579d0d.tar
guix-fbc5e7fc40919a66a24855430f7b32a304579d0d.tar.gz
gnu: packages: Remove x86_64-gnu next to i586-gnu from supported-systems.
* gnu/packages/golang.scm (go-1.16)[supported-systems]: Remove "x86_64-gnu". * gnu/packages/linux.scm (proot)[supported-systems]: Likewise. * gnu/packages/valgrind.scm (valgrind)[supported-systems]: Likewise. * gnu/packages/virtualization.scm (qemu)[supported-systems]: Likewise. * gnu/packages/heads.scm (musl-cross)[supported-systems]: Delete target-hurd? instead of remove'ing "i586-gnu". * gnu/packages/linux.scm (net-tools)[supported-systems]: Likewise. (libcap)[supported-systems]: Likewise. (fuse)[supported-systems]: Likewise. (kmod)[supported-systems]: Likewise. (lvm2)[supported-systems]: Likewise. (mdadm)[supported-systems]: Likewise. (proot)[supported-systems]: Likewise. * gnu/packages/lisp.scm (ecl)[supported-systems]: Likewise. (sbcl)[supported-systems]: Likewise. * gnu/packages/virtualization.scm (qemu)[supported-systems]: Likewise. Change-Id: I506e056b7aeb40f004fcc31ee85962cb065eac29
-rw-r--r--gnu/packages/golang.scm3
-rw-r--r--gnu/packages/heads.scm6
-rw-r--r--gnu/packages/linux.scm14
-rw-r--r--gnu/packages/lisp.scm5
-rw-r--r--gnu/packages/valgrind.scm4
-rw-r--r--gnu/packages/virtualization.scm2
6 files changed, 20 insertions, 14 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 95aa1eb8de..62ca230cf2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2024 Greg Hogan <code@greghogan.com>
;;; Copyright © 2024 Brennan Vincent <brennan@umanwizard.com>
;;; Copyright © 2024 André Batista <nandre@riseup.net>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -472,7 +473,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
("go-fix-script-tests.patch" ,(search-patch "go-fix-script-tests.patch"))
,@(package-native-inputs go-1.4)))
(supported-systems (fold delete %supported-systems
- (list "powerpc-linux" "i586-gnu")))))
+ (list "powerpc-linux" "i586-gnu" "x86_64-gnu")))))
;; https://github.com/golang/go/wiki/MinimumRequirements#microarchitecture-support
(define %go-1.17-arm-micro-architectures
diff --git a/gnu/packages/heads.scm b/gnu/packages/heads.scm
index 268d4d0198..e03f8014c2 100644
--- a/gnu/packages/heads.scm
+++ b/gnu/packages/heads.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,7 +46,8 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages version-control)
#:use-module (gnu packages virtualization)
- #:use-module ((guix build utils) #:select (alist-replace)))
+ #:use-module ((guix build utils) #:select (alist-replace))
+ #:use-module (srfi srfi-1))
(define-public musl-cross
(let ((revision "3")
@@ -158,7 +160,7 @@ done
(uri "http://www.musl-libc.org/releases/musl-1.1.24.tar.gz")
(sha256
(base32 "18r2a00k82hz0mqdvgm7crzc7305l36109c0j9yjmkxj2alcjw0k"))))))
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(home-page "https://github.com/osresearch/heads")
(synopsis "Musl-cross gcc 5 toolchain")
(description "Musl-cross toolchain: binutils, gcc 5 and musl.")
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a7139f7095..7ad853a513 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3585,7 +3585,7 @@ inadequately in modern network environments, and both should be deprecated.")
(string-append "mandir=/share/man")))))
(native-inputs `(("gettext" ,gettext-minimal)
("unzip" ,unzip)))
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(synopsis "Tools for controlling the network subsystem in Linux")
(description
"This package includes the important tools for controlling the network
@@ -3626,7 +3626,7 @@ configuration (iptunnel, ipmaddr).")
"BUILD_CC=gcc")
'()))))
(native-inputs (list perl))
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(home-page "https://sites.google.com/site/fullycapable/")
(synopsis "Library for working with POSIX capabilities")
(description
@@ -3998,7 +3998,7 @@ or kill them altogether.")
(setenv "UDEV_RULES_PATH"
(string-append #$output
"/lib/udev/rules.d"))))))))
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(home-page "https://github.com/libfuse/libfuse")
(synopsis "Support file systems implemented in user space")
(description
@@ -4468,7 +4468,7 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
"modinfo" "depmod")))))))
(native-inputs (list pkg-config zstd)) ;zstd needed for tests
(inputs (list xz zlib `(,zstd "lib")))
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(home-page "https://www.kernel.org/")
(synopsis "Kernel module tools")
(description "Kmod is a set of tools to handle common tasks with Linux
@@ -4828,7 +4828,7 @@ one to send arbitrary keycodes when a given key is tapped or held.")
;; The tests use 'mknod', which requires root access.
#:tests? #f))
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(home-page "https://sourceware.org/lvm2/")
(synopsis "Logical volume management for Linux")
(description
@@ -5940,7 +5940,7 @@ MPEG-2 and audio over Linux IEEE 1394.")
#:tests? #f))
(inputs
(list eudev))
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(home-page "http://neil.brown.name/blog/mdadm")
(synopsis "Tool for managing Linux Software RAID arrays")
(description
@@ -8793,7 +8793,7 @@ Text-based output formats: CSV, XML, Netfilter's LOG, Netfilter's conntrack
;; Many architectures are not supported (see:
;; https://github.com/proot-me/proot/blob/master/src/arch.h#L51).
(supported-systems '("x86_64-linux" "i686-linux"
- "armhf-linux" "aarch64-linux" "i586-gnu"))
+ "armhf-linux" "aarch64-linux" "i586-gnu" "x86_64-gnu"))
(arguments
;; Disable the test suite on armhf-linux, as there are too many
;; failures to keep track of (see for example:
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d2e80faf11..82ab70fd70 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 David Pflug <david@pflug.io>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -696,7 +697,7 @@ enough to play the original mainframe Zork all the way through.")
(files '("etc")))))
(home-page "https://ecl.common-lisp.dev/")
(synopsis "Embeddable Common Lisp")
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(description "ECL is an implementation of the Common Lisp language as
defined by the ANSI X3J13 specification. Its most relevant features are: a
bytecode compiler and interpreter, being able to compile Common Lisp with any
@@ -1506,7 +1507,7 @@ be built as a stand-alone REPL interpreter.")
(variable "XDG_CONFIG_DIRS")
(files '("etc")))))
(home-page "https://www.sbcl.org/")
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(synopsis "Common Lisp implementation")
(description "Steel Bank Common Lisp (SBCL) is a high performance Common
Lisp compiler. In addition to the compiler and runtime system for ANSI Common
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index b50dabf9ca..1bf4975667 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Denis Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -85,7 +86,8 @@ management and threading bugs, and profile your programs in detail. You can
also use Valgrind to build new tools.")
;; https://valgrind.org/info/platforms.html
(supported-systems (fold delete %supported-systems
- '("i586-gnu" "armhf-linux" "riscv64-linux")))
+ '("i586-gnu" "x86_64-gnu"
+ "armhf-linux" "riscv64-linux")))
(license gpl2+)
;; Hide this variant so end users get the "interactive" Valgrind below.
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index b416d774d6..8db5d6cbd2 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -577,7 +577,7 @@ server and embedded PowerPC, and S390 guests.")
;; Several tests fail on MIPS; see <http://hydra.gnu.org/build/117914>.
(supported-systems (fold delete %supported-systems
- '("mips64el-linux" "i586-gnu")))))
+ '("mips64el-linux" "i586-gnu" "x86_64-gnu")))))
;; QEMU >= 8.1.0's riscv64 binfmt service is unreliable.
(define-public qemu-7.2.4