aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-06-03 12:15:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-06-05 09:35:40 +0300
commitf78b41a1e9ed281bc1bac9da5d7c1b5429640bad (patch)
tree8f2ad7c1d346c96a6776dfc977852a0389f36f69
parentbf202e8bdd10dbd01da391ef635d1a31197251c1 (diff)
downloadguix-f78b41a1e9ed281bc1bac9da5d7c1b5429640bad.tar
guix-f78b41a1e9ed281bc1bac9da5d7c1b5429640bad.tar.gz
gnu: ldc: Update to 1.38.0.
* gnu/packages/dlang.scm (ldc-bootstrap): Update to 1.38.0. (ldc)[arguments]: Adjust 'patch-paths-in-tests phase for changes in the test suite. Adjust 'disable-problematic-tests phase to change the skipped tests. Change-Id: I5315ed5d3fc7d08a97aa0b5677692fbf221bf0c1
-rw-r--r--gnu/packages/dlang.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 37d4ad5356..f8751571e6 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -148,14 +148,14 @@ to a minimal test case.")
(define ldc-bootstrap
(package
(name "ldc")
- (version "1.35.0")
+ (version "1.38.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/ldc-developers/ldc/releases"
"/download/v" version "/ldc-" version "-src.tar.gz"))
(sha256
- (base32 "186z4r1d8y4dfpv5cdqgz9al6w7qnfh9l4q9ws9w0xkcf29njabf"))))
+ (base32 "13pkg69wjj4ali4ikijicccpg8y6f2hghhb70z9lrqr2w3pkhqna"))))
(build-system cmake-build-system)
(arguments
`(#:disallowed-references (,tzdata-for-tests)
@@ -257,9 +257,10 @@ bootstrapping more recent compilers written in D.")
"/lib/linux\",\n"))))))
(add-after 'unpack 'patch-paths-in-tests
(lambda _
- (substitute* '("tests/dmd/Makefile"
- "runtime/druntime/test/profile/Makefile")
+ (substitute* "runtime/druntime/test/profile/Makefile"
(("/bin/bash") (which "bash")))
+ (substitute* "tests/driver/cli_CC_envvar.d"
+ (("cc") (which "clang")))
(substitute* "tests/linking/linker_switches.d"
(("echo") (which "echo")))
(substitute* "tests/dmd/dshell/test6952.d"
@@ -276,9 +277,6 @@ bootstrapping more recent compilers written in D.")
;; The following tests plugins we don't have.
(delete-file "tests/plugins/addFuncEntryCall/testPlugin.d")
(delete-file "tests/plugins/addFuncEntryCall/testPluginLegacy.d")
- ;; The following tests requires AVX instruction set in the CPU.
- (substitute* "tests/dmd/runnable/cdvecfill.sh"
- (("^// DISABLED: ") "^// DISABLED: linux64 "))
;; This unit test requires networking, fails with
;; "core.exception.RangeError@std/socket.d(778): Range
;; violation".
@@ -288,13 +286,18 @@ bootstrapping more recent compilers written in D.")
;; The GDB tests suite fails; there are a few bug reports about
;; it upstream.
(for-each delete-file (find-files "tests" "gdb.*\\.(c|d|sh)$"))
- (delete-file "tests/dmd/runnable/debug_info.d")
(delete-file "tests/dmd/runnable/b18504.d")
(substitute* "runtime/druntime/test/exceptions/Makefile"
((".*TESTS\\+=rt_trap_exceptions_drt_gdb.*")
""))
;; Unsupported with glibc-2.35.
(delete-file "tests/dmd/compilable/stdcheaders.c")
+ (delete-file "tests/dmd/compilable/test23958.c")
+ (delete-file "tests/dmd/runnable/test23889.c")
+ (delete-file "tests/dmd/runnable/test23402.d")
+ (delete-file "tests/dmd/runnable/helloc.c")
+ ;; Only works in 2024 and without SOURCE_DATE_EPOCH
+ (delete-file "tests/dmd/compilable/ddocYear.d")
;; Drop gdb_dflags from the test suite.
(substitute* "tests/dmd/CMakeLists.txt"
(("\\$\\{gdb_dflags\\}") ""))