aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-11 21:19:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:57 -0400
commitf618a5e2d730b2af1847e0dd96cd8d1ee6dca86c (patch)
treea937d8a6d82780b5f62efda9d8be24e964203659
parente4bf10ab0bc7c397fe7cbc52aea87d5ea2dfda7d (diff)
downloadguix-f618a5e2d730b2af1847e0dd96cd8d1ee6dca86c.tar
guix-f618a5e2d730b2af1847e0dd96cd8d1ee6dca86c.tar.gz
gnu: libofx: Update to 0.10.7.
* gnu/packages/finance.scm (libofx): Update to 0.10.7. [arguments]: Use gexps. [configure-flags]: Use search-input-directory. [inputs]: Remove labels.
-rw-r--r--gnu/packages/finance.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 849f9aba99..f8bacc2fe8 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1639,7 +1639,7 @@ a client based on Qt. This is a fork of Bitcoin Core.")
(define-public libofx
(package
(name "libofx")
- (version "0.9.15")
+ (version "0.10.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1648,14 +1648,15 @@ a client based on Qt. This is a fork of Bitcoin Core.")
(file-name (git-file-name name version))
(sha256
(base32
- "1jx56ma351p8af8dvavygjwf6ipa7qbgq7bpdsymwj27apdnixfy"))))
+ "1k3ygavyb9b3f1ra62dsa46iiia0a1588yn3zy7bh7w4vfcrbd6d"))))
(build-system gnu-build-system)
(arguments
- '(#:parallel-build? #f ;fails with -j64
- #:configure-flags
- (list (string-append "--with-opensp-includes="
- (assoc-ref %build-inputs "opensp")
- "/include/OpenSP"))))
+ (list
+ #:parallel-build? #f ;fails with -j64
+ #:configure-flags
+ #~(list (string-append "--with-opensp-includes="
+ (search-input-directory %build-inputs
+ "include/OpenSP")))))
(native-inputs
(list autoconf
automake
@@ -1664,9 +1665,9 @@ a client based on Qt. This is a fork of Bitcoin Core.")
libtool
pkg-config))
(inputs
- `(("curl" ,curl)
- ("libxml++-2" ,libxml++-2)
- ("opensp" ,opensp)))
+ (list curl
+ libxml++-2
+ opensp))
(home-page "http://libofx.sourceforge.net/")
(synopsis "Library supporting the Open Financial Exchange format")
(description