aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Lerique <sl@eauchat.org>2024-04-28 23:10:36 +0200
committer宋文武 <iyzsong@member.fsf.org>2024-04-29 08:43:25 +0800
commitf1bcbdbde7ecb6a8ce0fd7b1d54691d6ee1940e9 (patch)
treed17770c5483b18ad2da8a8348913c99253865a3b
parent72432080ad52aec261ae8a74afc3a2ee7254914a (diff)
downloadguix-f1bcbdbde7ecb6a8ce0fd7b1d54691d6ee1940e9.tar
guix-f1bcbdbde7ecb6a8ce0fd7b1d54691d6ee1940e9.tar.gz
gnu: Add hexahop.
* gnu/packages/games.scm (hexahop): New variable. Change-Id: Id7a998d18c391af8d9722d2e637988ca019db304 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/games.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 57e6c23f41..1305bf426f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -81,6 +81,7 @@
;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2024 Sébastien Lerique <sl@eauchat.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -241,6 +242,34 @@
#:use-module ((srfi srfi-1) #:hide (zip))
#:use-module (srfi srfi-26))
+(define-public hexahop
+ (package
+ (name "hexahop")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/hexahop/" version "/"
+ "hex-a-hop-" version ".tar.gz"))
+
+ (sha256
+ (base32 "1mm069wpwc8nrrzfn2f64vh550634xlfws64bfmhqhx86vcikgw0"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "--with-sdl-prefix="
+ #$(this-package-input "sdl-union")))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list (sdl-union (list sdl sdl-mixer sdl-ttf))))
+ (home-page "https://sourceforge.net/projects/hexahop/")
+ (synopsis "Puzzle game navigating paths over hexagons")
+ (description
+ "Hex-a-hop is a puzzle game in which a girl has to destroy green hexagons
+by stepping on them.")
+ (license license:gpl2+)))
+
(define-public abe
(package
(name "abe")