aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-18 22:15:31 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-28 21:12:16 +0100
commitef13f34f00dbd32791531ce93ea1c91b80c36b79 (patch)
tree7eb0a37b069f81e7fc00965a062def5882b2fafa
parentb8f5e351c3e429a5ae4b134ffba91999b2ac7f1d (diff)
downloadguix-ef13f34f00dbd32791531ce93ea1c91b80c36b79.tar
guix-ef13f34f00dbd32791531ce93ea1c91b80c36b79.tar.gz
gnu: Add ruby-ref.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index eeba965801..91421b8ba0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -416,6 +416,36 @@ packaging native C and Java extensions in Ruby.")
hosts by wrapping the @file{rsync} binary.")
(license license:expat)))
+(define-public ruby-ref
+ (package
+ (name "ruby-ref")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Tests are not distributed at rubygems.org so download from GitHub
+ ;; instead.
+ (uri (string-append "https://github.com/ruby-concurrency/ref/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1090z8vzf8bf7gx3akvrn4alcklyanbg6hipjmzlzkx0lr1l5zj4"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (synopsis
+ "Library that implements weak, soft, and strong references in Ruby that work
+across multiple runtimes (MRI, Jruby and Rubinius). Also includes implementation
+of maps/hashes that use references and a reference queue.")
+ (description
+ "Library that implements weak, soft, and strong references in Ruby that work
+across multiple runtimes (MRI, Jruby and Rubinius). Also includes
+implementation of maps/hashes that use references and a reference queue.")
+ (home-page
+ "http://github.com/ruby-concurrency/ref")
+ (license license:expat)))
+
(define-public ruby-i18n
(package
(name "ruby-i18n")