aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 21:56:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:48 +0100
commite0a80ee4428523107386dea34b0d4d85f2d7ba8d (patch)
treea0c69abd6c0c9302028d006c04b74054d55242e9
parentce4ac7d56e6e8abd27fb211a3b6ee378165ce92f (diff)
downloadguix-e0a80ee4428523107386dea34b0d4d85f2d7ba8d.tar
guix-e0a80ee4428523107386dea34b0d4d85f2d7ba8d.tar.gz
gnu: mps-youtube: Fetch sources from git.
* gnu/packages/video.scm (mps-youtube)[source]: Fetch from git.
-rw-r--r--gnu/packages/video.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 41add12be7..7ceb8f61ce 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2394,13 +2394,14 @@ Content System specification.")
(version "0.2.8")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/mps-youtube/mps-youtube/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mps-youtube/mps-youtube.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0x7cmfh199q9j396v7bz81nnvanfllhsg86489i5dw2p3yyc9wnm"))))
+ "1w1jhw9rg3dx7vp97cwrk5fymipkcy2wrbl1jaa38ivcjhqg596y"))))
(build-system python-build-system)
(arguments
;; Tests need to be disabled until #556 upstream is fixed. It reads as if the