aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-03-26 15:45:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-03-27 10:17:45 +0100
commitd5a5d50932fd17981550f0416dcfddbd2b09af28 (patch)
tree99053c81568fb5c3be5e9dca1c6d875596c75062
parent13d1211a72597336a2a7ebf352d0b6301bd41cdb (diff)
downloadguix-d5a5d50932fd17981550f0416dcfddbd2b09af28.tar
guix-d5a5d50932fd17981550f0416dcfddbd2b09af28.tar.gz
gnu: Add castxml.
* gnu/packages/cpp.scm (castxml): New variable. Change-Id: I11fe3bce19a1bdb1170aa81547574836a823bcb8
-rw-r--r--gnu/packages/cpp.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d451eea2fd..acbe3e4836 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -91,6 +91,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -184,6 +185,37 @@ allocator that makes it easy to generate complex code without a significant
development effort.")
(license license:zlib))))
+(define-public castxml
+ (package
+ (name "castxml")
+ (version "0.6.4")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/CastXML/CastXML")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l5ys9zmllfgwhjrm897akbsf38iswfcarhxg27xfhiy0bmzcwsg"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list
+ (string-append "-DCLANG_RESOURCE_DIR="
+ #$(this-package-native-input "clang") "/lib/clang/"
+ #$(version-major
+ (package-version (this-package-native-input "clang")))))))
+ (inputs (list libffi))
+ (native-inputs (list clang-17 llvm-17))
+ (home-page "https://github.com/CastXML/CastXML")
+ (synopsis "C-family abstract syntax tree XML output")
+ (description "CastXML is a C-family abstract syntax tree XML output tool.
+This project is maintained by Kitware in support of ITK, the Insight
+Segmentation and Registration Toolkit.")
+ (license license:asl2.0)))
+
(define-public range-v3
(package
(name "range-v3")