aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-08 10:17:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-08 19:52:54 +0200
commitd521c2dcbaf9e13a8d95569032b203353a766b1f (patch)
tree14c104fbbcc6d9187eef1d298dd66bd3adac9747
parent82babf242e2e441a6d49138f7cddbd5182b8d9be (diff)
downloadguix-d521c2dcbaf9e13a8d95569032b203353a766b1f.tar
guix-d521c2dcbaf9e13a8d95569032b203353a766b1f.tar.gz
gnu: julia: Also skip tests when cross-compiling.
* gnu/packages/julia.scm (julia)[arguments]: Don't run the test suite when cross-compiling.
-rw-r--r--gnu/packages/julia.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 9f3ef031c3..5e6d188ec4 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -164,7 +164,8 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
;; The test suite takes many times longer than building and
;; can easily fail on smaller machines when they run out of memory.
- #:tests? ,(not (target-aarch64?))
+ #:tests? ,(not (or (%current-target-system)
+ (target-aarch64?)))
;; Do not strip binaries to keep support for full backtraces.
;; See https://github.com/JuliaLang/julia/issues/17831